Grand Theft Auto: San Andreas

Grand Theft Auto: San Andreas

View Stats:
TheGuyNL Jan 19, 2014 @ 4:26am
GTA San Andreas with Windows 8.1: Requires at least DirectX version 9.0
Hello everyone,

A few weeks ago I had to reinstall my system, I was running Windows 8.1 (upgraded from Windows 8) and enjoyed playing GTA SA alot those days. But I reinstalled and just installed straight Windows 8.1 (as I have got a dreamspark account, I get free licenses) and though of installing GTA SA again. This was all fine until I tried to launch it. I got this error saying: 'GTA SA requires at leats DirectX version 9.0' (pic: http://i.imgur.com/aag7QR5.png). So I updated DirectX and still nothing, tried all things I could find on google from compatibility mode to reinstalling Silverlight. Nothing seems to help. So now I am here asking you guys. Does any of you know a way to fix this? It will amaze me and I will be extremely thankfull! (Maybe even a free game for the one who tells me how to fix this)

So let me know if you got something, I would be grateful to get it running again as I love the game.

Thanks in advance!
< >
Showing 1-15 of 16 comments
[BR]Sherlock_Holmes Jan 19, 2014 @ 11:40am 
A have the same problem ¬¬"

TheGuyNL Jan 20, 2014 @ 3:15am 
Originally posted by Sherlock_Holmes:
A have the same problem ¬¬"

So sad
Any people's to help?? D:

I need play GTA SA.....

I NEED kkkkkkkkkkkk"
i cant even get an error nothing happens wen i pres play
i have also 8.1 help me pls
thefireguy98 Feb 12, 2014 @ 11:23am 
how to fix this:
step 1: go to www.virtualbox.org
step 2: install a windows 7 is0
step 3: install the game to the virtual machine
works for me
TheGuyNL Feb 12, 2014 @ 11:40am 
That's not optimal as you will be playing in a virtual machine.
vvn Mar 8, 2014 @ 3:35am 
Install DirectPlay from Control Panel => Programs and Features => Turn Windows features on or Off => Legacy components => DirectPlay
Originally posted by vvn:
Install DirectPlay from Control Panel => Programs and Features => Turn Windows features on or Off => Legacy components => DirectPlay
Thank you very much! It fixed it for me! :)
InstaREKT Mar 17, 2015 @ 11:01am 
Originally posted by vvn:
Install DirectPlay from Control Panel => Programs and Features => Turn Windows features on or Off => Legacy components => DirectPlay
Worked for me...had to reinstall Windows 8.1 though. Why I didn't stay with Windows 8? Everything was getting glitchier by the day...keyboard lags, the Windows 8 start menu was all messed up, and the computer was generally screwing up too. Also, my eyes were hurting from staring at the start menu. Completely red, no background...ouch.
my problems with Windows 8.1 are those that while it is fine but I can not move the mouse and do not know what settings should I bring up the keyboard
+ mouse anyone tell me why how fix this
Gaya_PT Mar 18, 2015 @ 12:11pm 
I have the same problem with ingame playing... the mouse doesn't work!! Does anyone knows how to solve it? :(
Silent Mar 18, 2015 @ 12:16pm 
The same solution ;)
Gaya_PT Mar 18, 2015 @ 12:41pm 
Originally posted by Silent:
The same solution ;)

Thank you, Silent!! It worked just fine!! And now... the fun starts!! :D
ChillToad Apr 14, 2015 @ 10:50am 
Thanks for this ... It worked!

Originally posted by vvn:
Install DirectPlay from Control Panel => Programs and Features => Turn Windows features on or Off => Legacy components => DirectPlay
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Date Posted: Jan 19, 2014 @ 4:26am
Posts: 16