oekonen Jul 30 @ 5:00am
GTA:SA mouse not working windows 8.1.
In menu, mouse moves, but you cant click anything, in-game, it doesnt work at all... I have tried dll solution, but it didnt work, i hvae tried compatibility mode, it didnt either. Im having 7 cpu's and i have already tried using GTA:SA with only one. I hvae spent hours looking for solution.
Showing 1-8 of 8 comments
< >
Powl Jul 30 @ 5:21am 
first off, you dont have 7 CPUs. You have one CPU with either 8 cores in 4 modules (FX8000) or 4 cores with 8 threads (i7 quad).

Second, I suggest you move/post this in the GTA:SA discussions? This is for Hardware and OS, and while your issue is involving hardware and OS, so is every single problem one can have on a PC. However your specific issue so far appears to be specific to GTA:SA and as that is better posted in the respective discussion.
oekonen Jul 30 @ 10:46am 
Thanks for the info, ill do that.
Gipper Jul 30 @ 8:12pm 
having the exact same problem where none of these solutions work really hope someone knows another fix or something thatll work
{LS.G} Stealth Gamer Aug 10 @ 2:58am 
Originally posted by Powl:
This is for Hardware and OS.
Um what? lol
Powl Aug 10 @ 4:27am 
Originally posted by Dubstep_Bass:
Originally posted by Powl:
This is for Hardware and OS.
Um what? lol
He initially posted this in the Hardware and OS subsection. It has been moved since.
ScottyMclean Aug 13 @ 11:30pm 
Just to end this issue once and for all. SA was back around 2005ish and rockstar is not at all interested in making support for newer OS. To fix this issue, you need to download a custom DLL for DX Input and place it in the root of SA's install (steam apps). The stock install of SA 3.0 via steam does not have this file in it's system because the game engine accesses a file from system32. Placing the DLL in SA's Root will basically only alter SA's mouse input and not every other game on your system that needs that file.

Working and tested on Windows 8.1 on a Quad Core AMD A6 3420m APU with 6520g Radeon, 4GB DDR3 ram. (So far played into verry late game with this fix and not had any issues. Menus work, all mouse buttons work).

https://www.dropbox.com/s/a7fzj5xgvyirc4i/Mouse%20Fix%20%28old%20games%20DLL%29.zip

*NOTE* this is a link to my personal dropbox. The file shouldnt move, but in the event that it does and it is no longer accessable - do a google search for DINPUT8.DLL san andreas fix. Hopefully some websites are still hosting the file.
Last edited by ScottyMclean; Aug 13 @ 11:31pm
TypicalRookie Aug 19 @ 6:49pm 
Thanks ScottyMclean, that dll fixed the mouse problems for me
ScottyMclean Aug 19 @ 7:19pm 
No problem! :D Gotta keep great game alive right?
Showing 1-8 of 8 comments
< >
Per page: 15 30 50