EtaYorius Aug 13, 2014 @ 9:19am
Horrible Performance with Latest GeForce Drivers, and FIX
I tried replaying this game couple days ago, but i noticed the peformance was extremely bad, i was hitting from 15-22 fps even without the frame limit option, i tried everything from setting the Compatibily options to Win98/ME, Defragging HDDs but nothing worked, sometimes the framerate would skyrocket for a couple seconds up to 60 but then it dropped very quick back to 15FPS... just when i was about to give up i noticed my save last save game Date was from Sep 2013, but i remember the game worked extremely well then at 60 FPS constant, so i decided to roll back my drivers just in case that was the reason for bad performance, i rolled back from 337.88 to 327.23 and VOILA! the game now runs at 60 FPS at all times.

that`s is quite odd, just before downgrading my Drivers i decided to try GTA3 and GTA:VC and all of them had horrible performance with 337.88, i have no idea what causes the new drivers to perform this bad on GTA3, SA and VC, so i recommend that you downgrade your drivers if you plan to play this Titles.

My System:
Windows7 X64
8GB DDR3 1600MHZ
AMD PhenomII 980 4GHZ
GeForce GTX470 (OC 727 MHZ)
Showing 1-8 of 8 comments
< >
SquirrlyNuts Aug 13, 2014 @ 10:50am 
you could try beta ones, they work for me.
EtaYorius Aug 13, 2014 @ 11:46am 
Ok thanks, i will and report if it worked.
EtaYorius Aug 13, 2014 @ 11:53am 
ala-smith, what Beta version you using?
SquirrlyNuts Aug 15, 2014 @ 3:49pm 
I used beta is what I was saying. I go to beta if I find a glitch or bug or when something isn't working. It’s kind of like the Steam client I have I know I can get a beta version but it's being sure that I can count on the beta having the fix. Right now I'm using NVidia normal driver version build 340.52 and the Steam normal client 2.0.0.0. Something’s are best left alone to pro's..... Esupport [www.esupport.com]is what I use to update things
Last edited by SquirrlyNuts; Aug 15, 2014 @ 3:54pm
EtaYorius Aug 17, 2014 @ 11:03pm 
Yeah it seems Latest WHQL (340.52) resolves the issue with 337.88 and works really well with GTA3, SA and VC.
titanicguy54 Aug 26, 2014 @ 9:54am 
ik i have OS: Windows 8 CPU:intel core i3 GPU: intel hd graphics
[FSG]Hoxton Aug 27, 2014 @ 3:16pm 
please make sure your TOASTER is plugged in
GmF|M4son Aug 29, 2014 @ 11:31am 
I have Windows 7, AMD Dual Core x64 2.2ghz, GTS450, MSI K8N, 4GB Ram SDRAM DDRAM (DDR1) and I run BF4 at high with 50 fps. GTA:SA should run perfectly on these specs...
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Aug 13, 2014 @ 9:19am
Posts: 8