Wonup Aug 21 @ 9:53am
Directx problem
i tried playing but it said error shows that i need directx version 8.1 to run it i used windows 8.1 with directx 11 and i cant install old versions help anyone?