Second Sight > General Discussions > Topic Details
Oooch Dec 9, 2012 @ 5:47pm
Shame it runs at 20fps
Waste of money
Showing 1-15 of 22 comments
< >
Fon Master Ion Dec 16, 2012 @ 2:32pm 
The game is a Console Port, from awhile ago, which is probably why it doesn't run well.

Now, that being said, I got the game on Gamecube, and it's much better/easier on Consoles.
Oooch Dec 16, 2012 @ 2:35pm 
Doesn't mean it should be so broken it runs at 20fps on a GTS 670.
Fon Master Ion Dec 16, 2012 @ 2:37pm 
Originally posted by Oooch:
Doesn't mean it should be so broken it runs at 20fps on a GTS 670.

Sometimes Newer Drivers make older games that used older drivers not work well.

This happens alot actually.
Oooch Dec 17, 2012 @ 3:13am 
I'm sure. They shouldn't sell it on steam if it's broken. The gog copy is broken also.
Fon Master Ion Dec 17, 2012 @ 12:14pm 
Originally posted by Oooch:
I'm sure. They shouldn't sell it on steam if it's broken. The gog copy is broken also.
You could always try messing around with settings in the Nvidia Control Panel (or w/e it's called) and set it up for this game.

When the game starts (the secondsight.exe file), it should use the options you have set it that control panel.

Now, I'm NOT saying it will Fix it, but there is a possibility it could.
Don't ask what to change, i don't have a NVidia Video Card.

It most likely will be trial and error.
Oooch Dec 17, 2012 @ 2:08pm 
Literally tried everything in there already.
UdaLung Feb 22, 2013 @ 9:51am 
I guess I was fortunate as I had absolutly no problems. It's a "quirky" game which many people dislike but I found it kind of unique
Slow Apr 2, 2013 @ 8:08am 
I'll never be able to play this game. When it just released I had 20 fps. Many years later I still have 20 fps. Welp.
Fon Master Ion Apr 2, 2013 @ 10:03am 
I tried it a week ago, and i was getting like 13 FPS.

I tried Modifying Controls, Changing game Compatibility, didn't help.
Oooch Apr 2, 2013 @ 11:54am 
I just tried it on my i5 3570k at 4.4ghz with a GTX 670 and still get less than 30fps lol
Fon Master Ion Apr 2, 2013 @ 1:24pm 
Okay, i just tried here: http://www.gog.com/forum/second_sight/consistently_low_fps



Originally posted by Link Above:
An update:
At support's suggestion, I tried disabling my 6200 graphics card in the device manager.

At first it didn't work, but after rebooting the FPS was never dropping below 60 FPS as I would expect. I've tried enabling the 6200 again, and it hasn't started running slow yet.

So I'm not sure quite what I did, but hopefully this will help anyone who has this same problem!

I tried that and it worked for me too.
(Now, i don't have that exact video card, and i have an ATI, but it should work.)

Disabling, Restart, then Re-Enable, then Restart again.
I wasn't able to test it while it was disabled, but after Re-Enabling it, no problems.

My FPS According to FRAPS is 60 FPS now.
Opening Videos may be 30 FPS, but it should go up to 60 FPS by the Main Menu.

Edit: Fixed Typos.
Oooch Apr 3, 2013 @ 10:28am 
Don't have an onboard GPU so this won't work for me :/
Fon Master Ion Apr 3, 2013 @ 4:27pm 
Originally posted by Oooch:
Don't have an onboard GPU so this won't work for me :/
I have an Actual Video Card. You can do it the same way.

Just go to Device Manager and Look at "Display Adapters".
That will be your Video Card.

Your ACTUAL Video Card does have a Driver, so it will be there.
Oooch Apr 3, 2013 @ 5:48pm 
Yeah the only thing in my Display Adapters is my GTX 670, no onboard GPU there.
Fon Master Ion Apr 3, 2013 @ 6:40pm 
Originally posted by Oooch:
Yeah the only thing in my Display Adapters is my GTX 670, no onboard GPU there.

You don't have to have onboard.

*NOTE* When you Disable the Driver, it will most likely Force Very Low 800x600 Resolution.
I'd Switch it to at LEAST 1024x768 so you can see something.

Disable the GTX 670 Driver in Device Manager.
What this will do is disable the driver to your video card, and use Default Drivers instead.
Restart Your Computer. After Restarting, Re-Enable the Driver.
Restart Your Computer Again.

Second Sight "Should" play at 60 FPS now.

It worked for my with my sh!tty ATI Radeon HD 4650 (1 GB DDR2).
That isn't Onboard, it's an Actual Video Card.

Actual Video Cards HAVE Drivers for them in Device Manager too.

I tried this on my video card and it make the game work fine.
Now the controls are another story, but i know that's the game itself.

-----------------------------------
Edited: Fixed Typos and explained things better.
Showing 1-15 of 22 comments
< >
Per page: 15 30 50