Queen Cupcake Feb 2 @ 12:56pm
Cossacks II not working
So, I wanted to relive my childhood and purchased Cossacks II: Napoleonic Wars today.
BUT! It is not working.

I have Win8.1/64bit, computer meets all the requirements, but when I try to launch it, it will not start.
First I got the message that Direct3D does not have enough visual memory. Later I got that "Could not read the pixel data/path" or something like that. I do not remember the message since I do not get that anymore. Every time I launch the game it only crashes and changes my screen resolution. Game will not start.

So I tried the patch fix. But I got this message http://imageshack.us/photo/my-images/535/asdasddv.png/ (not my picture, but the message is the same). I know Steam has this game isntalled elsewhere (and I do know where), but how could I show the new path to patchfix?

I'd love to play the game I paid my last money (poor student) for. Please help! Thank you all steamers!
Showing 1-3 of 3 comments
< >
dghaddow8 Mar 4 @ 11:04am 
i had the same problem i got the game cusor but the screen was black this is how i fixed mine
iam running windows 8.1 64 bit
goto your computer folder
select C drive, PROGRAM FILES (X86) open the STEAM FOLDER, COMMON FOLDER you should see all the cossacks game folders
open each one and look for the DMCR or ENGINE application highlight it and right mouse click to select PROPERTIES on the menu select COMPATIBILITY then tick the box COMPATIBILITY MODE and from the drop down menu select WINDOWS XP (SERVICE PACK 3) or WINDOWS 7 depending on what version of windows you are running then click APPLY and OK do this for all your cossacks games it worked for me
Queen Cupcake Mar 4 @ 2:17pm 
Thank you for your advice. Sadly, I did not work for me. I guess I can not play that after all :(
Showing 1-3 of 3 comments
< >
Per page: 15 30 50