Stacking > Discusiones generales > Detalles del tema
Info-High 8 de May, 2013 a las 21:09
Fullscreen modes on linux
On linux, when this game is switched to fullscreen, there is some kind of malfunction with the screen. Moving the mouse makes the screen move off and the desktop is visible. I got this game bundled through the HIB and first I thought it was just the engine for all Double Fine games since the same thing happens in Costume Quest, but then I tried Psychonauts and that game handles everything fine. I haven't tried the rest yet, but is there any workaround for the fullscreen mode in Stacking?

This is on Fedora 17 x86_64 with the current nvidia binary driver.
Última edición por Info-High; 8 de May, 2013 a las 21:11
Mostrando 1-5 de 5 comentarios
< >
Nibodhika 10 de May, 2013 a las 8:53 
I'm not experiencing this problem, running in Arch Linux x86_64 with the current AMD proprietary driver... could this be a problem with nvidia cards?
I.R. 10 de May, 2013 a las 11:48 
I have this problem on Ubuntu 13.04, Nvidia proprietary drivers. This problem occurs on Stacking and on Costume Quest.
pnarciso 10 de May, 2013 a las 13:29 
I have Nvidia, and I also have the issue. The game likes to revert back to 1280x800.
ryuanlu [Linux] 20 de May, 2013 a las 22:39 
Same here.

Whenever I start the game, it always change my screen resolution into 1280x720. I have to manually switch back to 1920x1080 through nvidia-settings.
WeAreGeek 3 de Jun, 2013 a las 17:33 
I too have this problem.

The screen (TV connected through the HDMI interface on my Nvidia GTX 650 Ti) switches to 1280x720 when starting the game, and then switches to the screen resolution I set up in the game configuration. However, as OP mentions, it acts like a virtual desktop, and when I move the mouse down or right, the screen pans and the desktop becomes visible.

But it indeed only seems to occur with Stacking and Costume Quest. Brütal Legend is fine, though. So not all Double FIne titles are affected.

A workaround for me is to assign keyboard shortcuts to xrandr commands and change screen resolution while the game is started. The game will then adapt to the screen resolution you've set.

1. Go to System Settings (gnome-control-center) ▸ Keyboard
2. Switch to the Shortcuts tab and add a new custom shortcut
3. Enter a Name (Set resolution to 1600x900)
4. Enter a command (xrandr --output HDMI-0 --mode 1600x900)
5. Finaly click in the shortcut column to set a keyboard shortcut.

E.g. I have my keyboard shortcuts like this:

- Ctrl+Shift+! = 1920x1080
- Ctrl+Shift+@ = 1600x900
- Ctrl+Shift+# = 1366x768
- Ctrl+Shift+$ = 1280x720

(Note: !@#$ are 1234 with Shift)

Apparantly it doesn't matter to which resolution I switch, the game just seems to scale up. Sometimes I need to switch twice, before it works without any glitches.

Anyway, I really think it's a game related issue (possibly in combination with Nvidia proprietary drivers and/or HDMI output). So far I have only encountered this with Stacking and Costume Quest

[edit: typos]
[edit2: possibly Nvida/HDMI? Anyone?]
Última edición por WeAreGeek; 3 de Jun, 2013 a las 17:56
Mostrando 1-5 de 5 comentarios
< >
Por página: 15 30 50