Monaco > Linux Technical Support > Topic Details
who Dec 15, 2013 @ 3:41pm
Startup Crash on Linux
So I just got this as a Steam Gift, happy me. But as soon as I try to boot, it crashes on boot.

I'm running it on Elementary OS, which is based off Ubuntu. It runs off the same display drivers as Ubuntu, I think. I'm also on a puny Asus netbook with 1024x600 resolution, so all of those things might be the cause of the problem here. I really wish I could find a way to fix it though. If someone could tell me whether they can run it at low-res, and on Ubuntu, without a problem that might help find the source of the problem.
Showing 1-15 of 22 comments
< >
Durgrobach Dec 15, 2013 @ 3:42pm 
When you open it, does it visibly crash, or simply refuse to run?
who Dec 15, 2013 @ 3:45pm 
Hey, thanks for the quick answer. I think it visibly crashes, because it goes into a black screen and then it comes back to the desktop. So something is going to start, but nothing is really rendered before it just pops back to the desktop. Just a black screen and then straight back.
Durgrobach Dec 15, 2013 @ 3:57pm 
I think the default resolution didn't automatically change for your laptop, so you'll have to go in and edit the resolution manually.

here's a link to a discussion which has all the info on how to do this:
http://steamcommunity.com/app/113020/discussions/3/630799997585021569/

Do note that your resolution should be 600.

If 600 doesn't work, then try 1024, although I'm not sure exactly what 1024x600 requires for the Options file.

Also ~ Apology for taking >10 minutes to respond again! Steam didn't automatically subscribe me to this discussion! xD
Last edited by Durgrobach; Dec 15, 2013 @ 3:58pm
who Dec 15, 2013 @ 4:43pm 
This is going to sound funny, but there's no SAVEDATA folder and no Options.xml file. I've told Steam to verify game cache and it goes to 100% no problems. I also went to the Terminal and tried ls -a. So, I suppose maybe the port is differently structured? Where do you think the Options.xml file could be, or should I make one?
Bobyl Dec 20, 2013 @ 5:06am 
Same problem here. Game does not launch when ran directly from Steam.

However, running it from command line does work (but it complains about not being ran from Steam making online multiplayer unavailable).
Durgrobach Dec 20, 2013 @ 7:37am 
I've sent the devs this bug, they'll be working on it. Hopefully it's solved soon! :(
Voxel8bitRoguelikeFPSSimulator Dec 20, 2013 @ 9:06am 
Same problem here, launching from steam causes CTD
biohaz Dec 20, 2013 @ 5:00pm 
When launching from steam, it gives me errors relating to voicechat, and crashes instantly, when run via the actual executable, It works, but no multiplayer (due to it running outside steam) Error is as follows:

[0] ------------- [WARNING] -------------> ClXACTEMULowLevel::cacheStreamingSound() -> FMOD system could not create streaming sound source [0xEADD388F] - [This command failed because System::init or System::setDriver was not called. ]!
[0] Load Timing -> Audio: 87.28
[0] ------------- [!ALERT!] -------------> FATAL ERROR: _setUpFMODDSPForVC() -> Failed to create custom FMOD DSP for Voicechat!

File: /builddir/Monaco/Code/Monaco/Steam/voicechat_MAC.cpp, line 220

Game removed: AppID 113020 "Monaco", ProcID 13949

Any help would be much appreciated :)
stabbyjones Dec 20, 2013 @ 8:27pm 
confirming the same problem on steamos and debian testing.

The options file isn't created using steam. the game will run outside of steam but not from the client. (it will create the options file then but when running from steam it doesn't get far enough to use the options file.)

[0] ------------- [WARNING] -------------> ClXACTEMULowLevel::cacheStreamingSound() -> FMOD system could not create streaming sound source [0xA08F2898] - [This command failed because System::init or System::setDriver was not called. ]!
[0] ------------- [WARNING] -------------> ClXACTEMULowLevel::cacheStreamingSound() -> FMOD system could not create streaming sound source [0xEADD388F] - [This command failed because System::init or System::setDriver was not called. ]!
[0] Load Timing -> Audio: 544.46
[0] ------------- [!ALERT!] -------------> FATAL ERROR: _setUpFMODDSPForVC() -> Failed to create custom FMOD DSP for Voicechat!

File: /builddir/Monaco/Code/Monaco/Steam/voicechat_MAC.cpp, line 220

Game removed: AppID 113020 "Monaco", ProcID 5508
Focused window is now 1, 0
Jarno + Jarno Dec 21, 2013 @ 7:06am 
I have that same problem.

Edit: Solution to fix the problem:
Run Monaco from its actual executable (<steam path>/SteamApps/common/Monaco/Monaco.bin.x86)
Go options -> change to windowed + set good resolution for windowed mode
Save + exit game
Run Monaco from steam
Go options -> change to fullscreen + resolution = your displays native resolution

That fixed problem for me, hope it helps :)
Last edited by Jarno + Jarno; Dec 21, 2013 @ 7:18am
Durgrobach Dec 21, 2013 @ 7:17am 
Thank you for providing the error codes mates. The devs are working on this issue, but haven't found the source yet. I'm sorry for the inconvenience, and thank you for your patience.

Hopefully this will be resolved soon! :(
biohaz Dec 21, 2013 @ 8:14am 
Originally posted by Jarno.deb:
I have that same problem.

Edit: Solution to fix the problem:
Run Monaco from its actual executable (<steam path>/SteamApps/common/Monaco/Monaco.bin.x86)
Go options -> change to windowed + set good resolution for windowed mode
Save + exit game
Run Monaco from steam
Go options -> change to fullscreen + resolution = your displays native resolution

That fixed problem for me, hope it helps :)

A) I have already tried this, and it is not the issue.
B) The issue is clearly something to do with the voicechat, assuming the error message is anything to pay attention to.
Jarno + Jarno Dec 21, 2013 @ 8:26am 
Originally posted by biohaz:

A) I have already tried this, and it is not the issue.
B) The issue is clearly something to do with the voicechat, assuming the error message is anything to pay attention to.

Yes, i know that the error is implying that there is something wrong with voicechat.
I had that same errormessage, and i dont know how but the errormessage does not appear anymore when i did what i told.
Bobyl Dec 21, 2013 @ 11:18am 
@Jarno.deb: your solution is not working on my setup. Monaco still does not run from Steam, even in windowed mode.
Bobyl Dec 25, 2013 @ 12:21am 
Aaah, crap. I just found what was preventing Monaco (and other gamesuch as SSZ or puddle) from running from Steam: I forgot to install lib32-alsa-oss and lib32-alsa-plugins.
Showing 1-15 of 22 comments
< >
Per page: 15 30 50