Monaco > Technical Problems > Topic Details
hahaha5367 Apr 27, 2013 @ 8:24am
Directx Error on Startup of Game
Every time i try to start up the game i end up detting a Directx error

The call 'CreateDevice' returned error "D3DERR_INVALIDCALL : Invalid Call"

Does anyone know how to fix this?
Showing 1-11 of 11 comments
< >
THANK YOU SANDROCK Apr 27, 2013 @ 8:38am 
Make sure your redist packages are up to date:

Microsoft Visual C++ 2010 Redistributable Package (x86)
http://www.microsoft.com/en-us/download/details.aspx?id=5555

DirectX End-User Runtimes (June 2010)
http://www.microsoft.com/en-us/download/details.aspx?id=8109


If you use an x64 system, you'll need those instead of the x86 above!
hahaha5367 Apr 27, 2013 @ 8:54am 
I tried this, but I still get the error
Thanks for your assistance anyway
THANK YOU SANDROCK Apr 27, 2013 @ 8:55am 
mmm have you tried running from the .exe?
hahaha5367 Apr 27, 2013 @ 8:56am 
Yes but I still get the error
Hurricane Mitch Apr 27, 2013 @ 2:24pm 
I am having the same issue. Windows 8 has newer versions of these redists and this may be the reason gor the failure, Monaco is probably using deprecated DirectX calls. Please help!
AndyN. @pixelatedpost  [developer] Apr 27, 2013 @ 3:47pm 
This is a known issue! We have our engine guys working on it right now!
Hurricane Mitch Apr 27, 2013 @ 6:46pm 
Thanks for the quick response!
Floyd Buchanan May 1, 2013 @ 1:41am 
I'm having the same problem. Any news on a fix?
undeadarego May 2, 2013 @ 7:45pm 
Same here.
NoRepro  [developer] May 2, 2013 @ 8:57pm 
If you are getting this error, please follow the instructions in this thread so I can get it fixed!
http://steamcommunity.com/app/113020/discussions/0/810923580559373369/
Hurricane Mitch May 23, 2013 @ 8:22pm 
Fixed for me with an update, thanks!
Showing 1-11 of 11 comments
< >
Per page: 15 30 50