mdrgaming Oct 13, 2013 @ 6:11pm
Avadon on Linux Mint 15 64-bit
I'm trying to get Avadon running on Mint as the title says, but after I select a resolution and window mode, the game crashes every time. Can't get it to run, and can't run it outside of steam either to try to debug. Starting up Avadon from the command line puts me in the wine window with a message that steam is required.

System:
Linux Mint 15 64-Bi6
Wine 1.6
NVidia GTX 550 w/nvidia driver 392.60
AMD 64 3500+ CPU
2GB Ram

I sent this to Steam since it's somewhat their issue as well as they decided to wrapper it, but thought I'd post here too since I saw that a developer also hangs out here. Here is the crash dump. Any ideas of something I can try? Again, this crash comes right after selecting the resolution (usually 1280x1024) and I've tried all three graphics modes (all graphics, some graphics, no graphics) and window and non-window modes. Doesn't make a difference.

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x0047dca0).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:0047dca0 ESP:0033ed10 EBP:0033fd7c EFLAGS:00210202( R- -- I - - - )
EAX:00000000 EBX:00000000 ECX:0033fd70 EDX:0033f570
ESI:02735528 EDI:00000000
Stack dump:
0x0033ed10: 00600388 0000049c 00000500 00bf5440
0x0033ed20: 10ca0000 00000388 0000049c 00000400
0x0033ed30: 00000500 005a8fc8 00000008 0047ea50
0x0033ed40: 00000000 00000000 00400000 00000000
0x0033ed50: 00000000 00010014 00000000 005b0948
0x0033ed60: fffffffd ffffffea 0000049f 0000038b
Backtrace:
=>0 0x0047dca0 in avadon (+0x7dca0) (0x0033fd7c)
1 0x0042cb74 in avadon (+0x2cb73) (0x0033fdc0)
2 0x00407487 in avadon (+0x7486) (0x0033fdd0)
3 0x004ab2ad in avadon (+0xab2ac) (0x0033fe60)
4 0x7b85f22c call_process_entry+0xb() in kernel32 (0x0033fe78)
5 0x7b8604ab in kernel32 (+0x504aa) (0x0033feb8)
6 0x7bc791c0 call_thread_func_wrapper+0xb() in ntdll (0x0033fed8)
7 0x7bc7c1cd call_thread_func+0x7c() in ntdll (0x0033ffa8)
8 0x7bc7919e RtlRaiseException+0x21() in ntdll (0x0033ffc8)
9 0x7bc4e45e call_dll_entry_point+0x33d() in ntdll (0x0033ffe8)
10 0xf75d576d wine_call_on_stack+0x1c() in libwine.so.1 (0x00000000)
11 0xf75d582b wine_switch_to_stack+0x2a() in libwine.so.1 (0xffb3a998)
12 0x7bc542c0 LdrInitializeThunk+0x3af() in ntdll (0xffb3aa08)
13 0x7b866a82 __wine_kernel_init+0xa21() in kernel32 (0xffb3bbb8)
14 0x7bc54a7b __wine_process_init+0x25a() in ntdll (0xffb3bc48)
15 0xf75d2ccc wine_init+0x2db() in libwine.so.1 (0xffb3bcb8)
16 0x7bf00f43 main+0xf2() in <wine-loader> (0xffb3c108)
17 0xf73ec935 __libc_start_main+0xf4() in libc.so.6 (0x00000000)
0x0047dca0: movb 0x0(%eax),%cl
Modules:
Module Address Debug info Name (122 modules)
PE 400000- 113b000 Export avadon
PE 10000000-100a3000 Deferred gameoverlayrenderer
PE 30000000-302c4000 Deferred steam
PE 38000000-387b1000 Deferred steamclient
PE 3b400000-3b41e000 Deferred steam_api
PE 3f000000-3f0ad000 Deferred tier0_s
PE 3f600000-3f64b000 Deferred vstdlib_s
PE 60000000-60021000 Deferred cserhelper
ELF 7b800000-7ba5b000 Dwarf kernel32<elf>
\-PE 7b810000-7ba5b000 \ kernel32
ELF 7bc00000-7bcda000 Dwarf ntdll<elf>
\-PE 7bc10000-7bcda000 \ ntdll
ELF 7bf00000-7bf04000 Dwarf <wine-loader>
ELF 7cd32000-7cd49000 Deferred libresolv.so.2
ELF 7cd49000-7cd51000 Deferred libogg.so.0
ELF 7cd51000-7cd7d000 Deferred libvorbis.so.0
ELF 7cd7d000-7cef5000 Deferred libvorbisenc.so.2
ELF 7cef5000-7cf45000 Deferred libflac.so.8
ELF 7cf45000-7cf4c000 Deferred libasyncns.so.0
ELF 7cf4c000-7cfc0000 Deferred libsndfile.so.1
ELF 7cfc0000-7cfca000 Deferred libwrap.so.0
ELF 7cfca000-7d014000 Deferred libdbus-1.so.3
ELF 7d014000-7d07f000 Deferred libpulsecommon-3.0.so
ELF 7d07f000-7d0ce000 Deferred libpulse.so.0
ELF 7d0f3000-7d11b000 Deferred winepulse<elf>
\-PE 7d100000-7d11b000 \ winepulse
ELF 7d11b000-7d133000 Deferred libxcb-glx.so.0
ELF 7d133000-7d18c000 Deferred libgl.so.1
ELF 7d802000-7d80c000 Deferred libjson.so.0
ELF 7d80c000-7d823000 Deferred libglapi.so.0
ELF 7d87a000-7d887000 Deferred libdrm.so.2
ELF 7d887000-7d88c000 Deferred libxcb-dri2.so.0
ELF 7d88c000-7d88f000 Deferred libx11-xcb.so.1
ELF 7d892000-7d8b4000 Deferred mmdevapi<elf>
\-PE 7d8a0000-7d8b4000 \ mmdevapi
ELF 7d8d6000-7d8f3000 Deferred libgcc_s.so.1
ELF 7d8f3000-7d95b000 Deferred dbghelp<elf>
\-PE 7d900000-7d95b000 \ dbghelp
ELF 7d95b000-7d96f000 Deferred libp11-kit.so.0
ELF 7d96f000-7da34000 Deferred libgnutls.so.26
ELF 7da92000-7da99000 Deferred libxfixes.so.3
ELF 7da99000-7da9d000 Deferred libxdamage.so.1
ELF 7da9d000-7daaf000 Deferred libtasn1.so.3
ELF 7daaf000-7db33000 Deferred libgcrypt.so.11
ELF 7db58000-7db85000 Deferred netapi32<elf>
\-PE 7db60000-7db85000 \ netapi32
ELF 7db85000-7dbb8000 Deferred secur32<elf>
\-PE 7db90000-7dbb8000 \ secur32
ELF 7dbb8000-7dbde000 Deferred iphlpapi<elf>
\-PE 7dbc0000-7dbde000 \ iphlpapi
ELF 7dbde000-7dbfc000 Deferred pdh<elf>
\-PE 7dbe0000-7dbfc000 \ pdh
ELF 7dbfc000-7dc6c000 Deferred setupapi<elf>
\-PE 7dc10000-7dc6c000 \ setupapi
ELF 7dc6c000-7dda0000 Deferred oleaut32<elf>
\-PE 7dc80000-7dda0000 \ oleaut32
ELF 7dda0000-7ddb4000 Deferred psapi<elf>
\-PE 7ddb0000-7ddb4000 \ psapi
ELF 7ddb4000-7de82000 Deferred crypt32<elf>
\-PE 7ddc0000-7de82000 \ crypt32
ELF 7de82000-7deb8000 Deferred uxtheme<elf>
\-PE 7de90000-7deb8000 \ uxtheme
ELF 7deb8000-7debe000 Deferred libxxf86vm.so.1
ELF 7debe000-7dec5000 Deferred libxdmcp.so.6
ELF 7dec5000-7dec9000 Deferred libxau.so.6
ELF 7dec9000-7deeb000 Deferred libxcb.so.1
ELF 7deeb000-7def1000 Deferred libuuid.so.1
ELF 7def1000-7df0b000 Deferred libice.so.6
ELF 7df0b000-7e042000 Deferred libx11.so.6
ELF 7e042000-7e054000 Deferred libxext.so.6
ELF 7e054000-7e05d000 Deferred libsm.so.6
ELF 7e061000-7e066000 Deferred libgpg-error.so.0
ELF 7e066000-7e080000 Deferred imagehlp<elf>
\-PE 7e070000-7e080000 \ imagehlp
ELF 7e082000-7e114000 Deferred winex11<elf>
\-PE 7e090000-7e114000 \ winex11
ELF 7e13d000-7e165000 Deferred libexpat.so.1
ELF 7e165000-7e19e000 Deferred libfontconfig.so.1
ELF 7e19e000-7e1b7000 Deferred libz.so.1
ELF 7e1b7000-7e252000 Deferred libfreetype.so.6
ELF 7e277000-7e29b000 Deferred imm32<elf>
\-PE 7e280000-7e29b000 \ imm32
ELF 7e29b000-7e2d1000 Deferred ws2_32<elf>
\-PE 7e2a0000-7e2d1000 \ ws2_32
ELF 7e2d1000-7e3d9000 Deferred comctl32<elf>
\-PE 7e2e0000-7e3d9000 \ comctl32
ELF 7e3d9000-7e453000 Deferred shlwapi<elf>
\-PE 7e3f0000-7e453000 \ shlwapi
ELF 7e453000-7e686000 Deferred shell32<elf>
\-PE 7e460000-7e686000 \ shell32
ELF 7e686000-7e6ce000 Deferred dsound<elf>
\-PE 7e690000-7e6ce000 \ dsound
ELF 7e6ce000-7e7dc000 Deferred opengl32<elf>
\-PE 7e6f0000-7e7dc000 \ opengl32
ELF 7e7dc000-7e807000 Deferred msacm32<elf>
\-PE 7e7e0000-7e807000 \ msacm32
ELF 7e807000-7e888000 Deferred rpcrt4<elf>
\-PE 7e810000-7e888000 \ rpcrt4
ELF 7e888000-7e9c4000 Deferred ole32<elf>
\-PE 7e8a0000-7e9c4000 \ ole32
ELF 7e9c4000-7ea33000 Deferred advapi32<elf>
\-PE 7e9d0000-7ea33000 \ advapi32
ELF 7ea33000-7eb51000 Deferred gdi32<elf>
\-PE 7ea40000-7eb51000 \ gdi32
ELF 7eb51000-7ecac000 Deferred user32<elf>
\-PE 7eb60000-7ecac000 \ user32
ELF 7ecac000-7ed66000 Deferred winmm<elf>
\-PE 7ecb0000-7ed66000 \ winmm
ELF 7ed66000-7ed73000 Deferred libnss_files.so.2
ELF 7ed73000-7ed7f000 Deferred libnss_nis.so.2
ELF 7ed7f000-7ed98000 Deferred libnsl.so.1
ELF 7ef98000-7efdb000 Deferred libm.so.6
ELF 7efe6000-7f000000 Deferred version<elf>
\-PE 7eff0000-7f000000 \ version
ELF f73d3000-f7586000 Dwarf libc.so.6
ELF f7586000-f758b000 Deferred libdl.so.2
ELF f758c000-f75a7000 Deferred libpthread.so.0
ELF f75a7000-f75b0000 Deferred libnss_compat.so.2
ELF f75c3000-f75cc000 Deferred librt.so.1
ELF f75cc000-f7782000 Dwarf libwine.so.1
ELF f7784000-f77a6000 Deferred ld-linux.so.2
ELF f77a6000-f77a7000 Deferred [vdso].so
Threads:
process tid prio (all id:s are in hex)
0000000e services.exe
0000001d 0
0000001c 0
00000014 0
00000010 0
0000000f 0
00000012 winedevice.exe
0000001b 0
00000018 0
00000017 0
00000013 0
00000019 plugplay.exe
0000001f 0
0000001e 0
0000001a 0
00000020 explorer.exe
00000022 0
00000021 0
00000023 Steam.exe
00000016 0
0000004a 0
0000004e 0
0000004d 0
0000004c 0
00000049 0
00000048 0
0000002e 0
00000025 0
00000026 0
00000027 0
0000003d 0
0000002d 0
0000000d 0
0000002b 0
0000002a 0
00000009 0
00000047 0
00000046 0
00000045 0
00000044 0
00000043 0
00000042 15
00000041 0
00000040 0
0000003e 0
0000003c 0
0000003b 0
0000003a 0
00000039 0
00000038 0
00000037 0
00000036 0
00000035 0
00000034 0
00000033 0
00000032 0
00000031 0
00000030 0
0000002f 0
0000002c 0
00000029 0
00000028 0
00000024 0
00000052 (D) C:\Program Files\Steam\steamapps\common\Avadon The Black Fortress\Avadon.exe
0000005a 0
00000056 0
00000055 15
00000053 0 <==
00000061 GameOverlayUI.exe
00000057 0
00000058 0
0000005e 0
0000005c 0
00000064 0
00000063 0
00000062 0
0000005f 0
0000005b 0
00000065 0
0000005d 0
00000060 0
System information:
Wine build: wine-1.6
Platform: i386
Host system: Linux
Host version: 3.8.0-26-generic
Showing 1-5 of 5 comments
< >
mdrgaming Oct 15, 2013 @ 3:29pm 
Boy, gotta admit, with this kind of service, the future of gaming is in good hands with Steam! Only thing steaming is me for being sold a broken product.
nello Oct 19, 2013 @ 2:31pm 
I agree it's not the best port for Linux. However, as others have mentioned, you could try creating/editing the file in

~/.local/share/Avadon/Avadon.ini

Mine is set to:

screenwidth=1920
screenheight=1080
fullscreen=1
gamespeed=0

. . . which seems to work for me. Hope that helps, and yeah, people shouldn't have to hack around with .ini or config files to get the game to work . . . it's quite an engrossing game when you do though.
mdrgaming Oct 20, 2013 @ 4:13am 
Thanks for your reply. I tried that, but it didn't work. I did try creating a blank one in case it was having trouble creating the file, but nothing, and adding in those values didn't have any effect.

Not getting any help from anyone. Everyone says it's someone else's problem. It is probably related to the 64 bit environment, but I guess Valve isn't interested in supporting Linux, just their own interests. I will be purchasing direct from Spiderweb in the future. I don't like that I have to be logged into Steam to play a single player game much either.
Nwii Oct 20, 2013 @ 8:02pm 
I wouldn't say Valve isn't interested in supporting Linux since they're big on it (with the Steam OS being Linux and all) but yeah...it sucks that this game can't run on your Linux Mint well.

If only I can help...I suggest doing a search on google
"avadon the black fortress linux" for some solution (as I seen a lot and maybe one of them may help in some way).

Though I learned that the problem you're having with the game...isn't Steams fault, it seems to be problematic for people even without using steam so yeah...but who am I to say, Linux on steam is still fairly new and in time these games will get the proper support in the future (especially with Steam OS coming).

Anyways take care, don't give up and rock on.
runequester Oct 27, 2013 @ 8:29pm 
I don't think it's 64 bit being the issue, since I've played the game on Ubuntu 64 bit, without any fuss.

You mention wine. Are you running it in wine or native?
Showing 1-5 of 5 comments
< >
Per page: 15 30 50