Blocks That Matter
McShifty1984 Oct 11, 2012 @ 11:32am
Unable to place blocks
Since the update I'm completely unable to place any blocks, either with a gamepad or keyboard. Anyone else had this problem?
< >
Showing 1-10 of 10 comments
nitram  [developer] Oct 11, 2012 @ 12:30pm 
Hi McShitfy1984,

Just to be clear: you can't place any blocks in-game? not in the level editor?

If it's in-game: do you see the cursor while in puzzle mode?
Can you switch between blocks with the L/R gamepad buttons (or the keyboard equivalent).

Thanks for the answers!
frankhjr Oct 11, 2012 @ 6:56pm 
I am having a similar problem. Playing on an Intel Mac via the keyboard, i can only go left, right, jump, and explode....D, E, F keys either don't work, or only make the little bot run in place if i press a direction arrow at the same time.
nitram  [developer] Oct 12, 2012 @ 1:55am 
Hi frankhjr!

Several questions:
- Have you tried to run the keyboard wizard to change bindings in the option menu?
My guess is that some keyboards are not allowing some of 3 combination keys at the same time (depending on how the keys are linked to the buses in the hardware).
By changing the bindings, maybe it can allow you to make the DEF new bindings work better.

- The keyboard was working after the last update?

- What is your keyboard?

- Can you try to open the "Console" application, and copy/paste any suspicious log related to keyboards?

Here we are testing with a Logitech UltraX (, and with the Apple wired Keyboard without Numeric Keypad, on a MacIntel MacMini.
McShifty1984 Oct 12, 2012 @ 11:42am 
I can't place the blocks during normal gameplay, not editing. As I have mentioned above this applies to both keyboard and gamepad. I am playing on Win 7 x64 BTW.
frankhjr Oct 13, 2012 @ 4:57pm 
Changed the bindings...same results. Using the mac thin aluminum usb keyboard with numeric keypad. This is the first time I have bought/tried to run the game, so I can't speak as to whether it worked with any other keyboard before/after any updates. Verifed game caches on both machines (see below) with no problems detected.
NOTE: Since this game is supposed to work with both Mac & PC, I loaded it up on my PC, and had the exact same problem. I hope this can be resolved, it looks like an interesting game.
McShifty1984 Oct 14, 2012 @ 11:46am 
FIXED. Just went through the keybindings and seems okay now.
Blastin_Heads Oct 15, 2012 @ 7:35am 
Originally posted by McShifty1984:
FIXED. Just went through the keybindings and seems okay now.
What exactly did u do,just need help, what did you use for key board bindings? example what keys?
McShifty1984 Oct 16, 2012 @ 10:30am 
I honestly haven't tried playing with the keyboard yet. I simply went through the gamepad calibration (pressing the buttons in the order you are told) and have been playing with the gamepad since. Sorry I can't be more helpful :(
frankhjr Oct 17, 2012 @ 9:04pm 
Still can't drill/play game. I do hope an update is coming to resolve the keyboard issues, as I don't wish to buy a $30 game controller to play a $2.50 game.
omg sad
< >
Showing 1-10 of 10 comments
Per page: 15 30 50