This topic has been pinned, so it's probably important
nitram  [developer] Feb 25, 2014 @ 6:31am
Changelog
1.1.0.4b (windows only)
- Game crash when launched in fullscreen on AMD/ATI cards: new options in the "BTM_DBG_launcher_win_bis.bat" and "BTM_launcher_win.exe" in the game folder (C:\Program Files (x86)\Steam\steamapps\common\blocks that matter). Should solve the crashing issue.

Thanks to John and Timo for experimenting stuff via emails!


1.1.0.4a (windows only)
- Windows executable will not try to search for an external JRE, but will use the embedded one
- Launch Options available: you can right click on the game in the library, choose Poperties, set the Launch Options in General Tab to be "-startwindowed 1" (without brackets) to force the game to launch in Windowed mode
Last edited by nitram; Feb 26, 2014 @ 6:08am
Showing 1-5 of 5 comments
< >
Beansprout Apr 30, 2014 @ 8:57am 
Hi. I was looking through videos about Bonus level "Back to the 90's", because I couldn't understand what am I supposed to do at all. And then, it turns out the level is bugged, it looks differently on videos I watched, and what's more, I don't get it why in one video someone mentions game version of 1.0.0.7, while mine is only 1.0.0.4b. Is 1.0.0.4b specifically highest version available for Windows, and 1.0.0.7 is version number for Linux release of BTM? Just curious, it confused me a little.
Anyway, the problem is about that bonus level, and most google search results are completely unrelated to the game. So I'd like to ask for help. And if there is more recent version of BTM for windows, why mine didn't update (I have it set to 'Always update this game as soon as possible' ) ? Here's the video with 1.0.0.7 number in the title I was talking about.
I can't do anything in this level, any help will be appreciated. Thanks.
SomeGuy712x Apr 30, 2014 @ 10:49am 
@ronery Kurumi:
Well, I'm using Windows 7, and it says that the game is version 1.1.0.4b on the title screen for me. And, I just tried out that level, and it worked correctly, just like in the video you linked to. Where exactly is the level bugged for you?
Last edited by SomeGuy712x; Apr 30, 2014 @ 10:49am
Beansprout Apr 30, 2014 @ 12:11pm 
Originally posted by SomeGuy712x:
@ronery Kurumi:
Well, I'm using Windows 7, and it says that the game is version 1.1.0.4b on the title screen for me. And, I just tried out that level, and it worked correctly, just like in the video you linked to. Where exactly is the level bugged for you?
It's not "bugged for me".
I was kind of in a hurry earlier, and "It turns out the level is bugged" among few other lines were bad choices of words, on my side. Apart from running Win 7 x64 Bit, the game also shows that it's 1.0.0.4b for me.
As for the bug - at first, like I mentioned earlier, I couldn't figure out what I should do to progress. Then I found two videos. The one you watched, yes it works, but in that video he fills the empty space with coloured blocks, and it activates stuff, and then those two long vertical collumns..actually, just look at 0:23 seconds - for me, and not only for me apparently, those 2 long collumns under Tetrobot with red, closed locks stay closed, and unavailable to fill with stone blocks later on.
And this is the second video, must be Xbox 360 version from the looks of it- but it plays differently, the collums are open the whole time, and that player doesn't even fill the empty 5-piece space with coloured blocks, just passes them and fills the 2 collumns with stone blocks. This is where the confusion comes from - why? I found that video before the other one I linked to in my previous post, and as soon as I saw the guy just runs, and fills the collums with stone blocks, I came back in the game to try the same. Nope, they're all locked down.
I'm going to try that combination of coloured blocks and put them in place, and see if it works. Anyway, how does one figure out they had to fill that space in order to progress, and with specific order at that? I'm writing this, because this level differentiates little too much from what I played through, in Adventure mode campaign.
EDIT: Nevermind, filling the coloured blocks worked. Even though everything I described above still sticks, I finished the level. Just not satisfied that I didn't solve the puzzle myself. There appears to be more differences, like in the next bonus level, called 'Hanging Garden'. When I drilled the box, I received 4 blocks of wood, and there's one ice block on top of the level. Since I failed to figure out how to solve that one too :/ I found a video, and there, they receive 3 x wooden, and 1 ice block after drilling the box and remaining 4th wooden block is on top instead. I wrote too much again dammit.
Last edited by Beansprout; Apr 30, 2014 @ 1:13pm
SomeGuy712x May 1, 2014 @ 4:55pm 
Huh. Yeah, that must be a different version of the level where the locked gates aren't present inside that structure. (If you're wondering, the colored blocks represent the colored buttons on a Super Famicom controller, and that structure is supposed to be a Super Famicom, where filling it with stone is supposed to represent inserting a game cartridge, I think.)

As for Hanging Garden, for me, I get four wood blocks from the crate and the ice block starts on the highest ledge, so I guess there are different versions of that level too. (Also, interestingly, the solution shown in that video is different from how I solved it. I attached my wood blocks to the ice block as it was falling, and in just the right spot, I can reach the goal from the horizontal wood platform I created in midair.)
Yuurg May 17, 2014 @ 5:24pm 
Any way to turn on the sound...?
Showing 1-5 of 5 comments
< >
Per page: 15 30 50