Alan Wake > General Discussions > Topic Details
xuande Apr 13, 2013 @ 6:20am
i bought this game 10 hours ago
so i finished downloading and started to play it
but how come it doesn't play smoothly
or it looks like it is running very slow and in slow motion.
i need a help because my friend recommended this game for me

running on intel core i5 3570k
evga gtx 680
corsair vengeance 16gb ram
windows home premium
Last edited by xuande; Apr 13, 2013 @ 6:22am
Showing 1-11 of 11 comments
< >
ISSACKLARK Apr 13, 2013 @ 1:16pm 
Lower your graphic settings especially the Light Ray effects that puts a load on the GPU , lastly lower the resolution if all else fails. Hope this helps !!!!!
xuande Apr 15, 2013 @ 3:12am 
lol lower everything will not help. i just installed the driver from nvidia website, and lastly my pc can handle any other new games as well fyi.
weeksy77 Apr 15, 2013 @ 3:22am 
Can't imagine why it wouldn't be running well on your machine - I've got a GTX 550ti and it runs perfectly on max settings.
xuande Apr 16, 2013 @ 2:57pm 
it is running well now, i just installed the driver from nvidia site
shaide Apr 18, 2013 @ 1:58am 
I was about to mention this very same thing, except the drivers wont work for me, since I just updated a few days ago, so should be all updated. Also like OP, all newer games run fine for me, and on max settings, but this game, even on lowest setting seems sluggish. Not really jerky or laggy, just sluggish..almost like slow motion.
xuande Apr 18, 2013 @ 9:41am 
try to lower your screen resolution. i just did that because i have a 27" screen this games doesn't run good in this resolution.
shaide Apr 19, 2013 @ 1:32am 
hmmm...thanks, ill try that!
shaide Apr 19, 2013 @ 1:40am 
Boom! worked like a charm! Thanks Xuande, now all I need to do is remove that annoying motion blue. -noblur works, but i heard theres a file somewhere that just removes motion blur, since -noblur removes the blurs around the taken as well.
Highway May 24, 2013 @ 9:50am 
shouldn't need to reduce a thing mines running totally maxed out smooth as silk... maybe try the new 320.18 beta drivers for ya 680
Quantum beast of 13th circle May 24, 2013 @ 4:12pm 
Funny :) I have 60fps smooth play maxed out in hd with old ♥♥♥ radeon and C2D :D
Valar morghulis May 25, 2013 @ 7:23am 
gtx460m 1.5 gb ddr5 60 fps on medium
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Apr 13, 2013 @ 6:20am
Posts: 11