Alan Wake > General Discussions > Topic Details
yaphes Dec 9, 2013 @ 7:59pm
I got only 15fps performance with my GTX660 Ti, What's the problem?
well, I have been played this game for almost 3 times and I really enjoy this one.

I used to play it with a 550m graphic card in a low graphic settings, recently i bought gtx660ti in order to enjoy the fantastic cutscenes in many games and it runs very well in other games with highest graphic settings such as Bioshock: Infinite and Withcer 2 etc except Alan Wake,one of my favourate games.. so sad. i can't even paly the lowest settings with my card smoothly(i got only 20fps...) it seems that my graphic card didn't work in this game because the GPU usage is only 40%.. i assure my graphic card has been turned on.

So can any help me to locate or even solve the problem? i really want to start a venture again with Alan Wake and feel the terrifying atmosphere in Brightfall Valley.
Last edited by yaphes; Dec 9, 2013 @ 8:00pm
Showing 1-15 of 20 comments
< >
Kourgette Dec 10, 2013 @ 6:26am 
I have the same problem and the same graphic card as you. The game freeze so much that I can't even play it... And I don't know what to do either... :(
Plaid Dec 10, 2013 @ 10:37am 
That's strange. I use GTX 660 (non-Ti) and get great performance, and that's with everything maxed out.

It sounds like you might be using a laptop and the game may not be using your preferred card.
Kourgette Dec 10, 2013 @ 11:03am 
As for me, I am not using a laptop... My processor is a i7-4770K (3.5 GHz) and I have 8 Go of RAM, so I shouldn't be having any problems of that kind. If somebody find a solution, let us know :)
yaphes Dec 10, 2013 @ 9:19pm 
Originally posted by Plaid:
That's strange. I use GTX 660 (non-Ti) and get great performance, and that's with everything maxed out.

It sounds like you might be using a laptop and the game may not be using your preferred card.
yes,that's really strange..well, the NVIDIA notification indicates that my GPU is working under this game but actually not.
yaphes Dec 10, 2013 @ 9:20pm 
Originally posted by Kourgette:
As for me, I am not using a laptop... My processor is a i7-4770K (3.5 GHz) and I have 8 Go of RAM, so I shouldn't be having any problems of that kind. If somebody find a solution, let us know :) :meaty:
I have registered in the official forum of remedy but I did'nt received any verication email so I can't submit the problem on their forum.
Maybe you could have a try on their forum. Good luck both of us..
Kourgette Dec 11, 2013 @ 4:23am 
All right, so I somehow managed to play the game without any problem! My graphic card driver crashed (It happens sometimes, no idea why) and I started lagging in any other games. So I rebooted my PC, and... Alan Wake was working perfectly. By the way, I never have any problem like that with non-steam games, so maybe the problem's Steam. ^^
yaphes Dec 11, 2013 @ 8:10am 
Originally posted by Kourgette:
All right, so I somehow managed to play the game without any problem! My graphic card driver crashed (It happens sometimes, no idea why) and I started lagging in any other games. So I rebooted my PC, and... Alan Wake was working perfectly. By the way, I never have any problem like that with non-steam games, so maybe the problem's Steam. ^^
Why are you so lucky T T..
yaphes Dec 11, 2013 @ 8:26am 
Originally posted by Kourgette:
All right, so I somehow managed to play the game without any problem! My graphic card driver crashed (It happens sometimes, no idea why) and I started lagging in any other games. So I rebooted my PC, and... Alan Wake was working perfectly. By the way, I never have any problem like that with non-steam games, so maybe the problem's Steam. ^^
Maybe it's the driver's problem..I'll replace the newest driver to some old one to see if I can fix the problem
RossMadness Dec 11, 2013 @ 1:27pm 
Try using the Geforce Experience reccommended settings for your system. Alternatively, if you go into your NVIDA Control Panel, go to the tree marked "3D Settings" and under "Adjust image settings with preview", make sure you have the radio marked for "Let the 3D Application Decide'. I personally have a 550Ti and it ran on high at 60 FPS. I added a second 550Ti and in SLI it runs at 65-70 FPS. Your newer card should run the game just as well, if not better. Just make sure you're not trying to force any quality settings. (I also run with VSYNC off just because I dislike it and I have FXAA off because that can KILL frame rates.)
Plaid Dec 11, 2013 @ 1:53pm 
I would actually recommend not installing Geforce Experience at all.
Just download and install the main driver and Physx software only (unless you need 3-d, then install the 3-d support).

Nvidia Geforce Experience thingy seems to cause more problems than anything for people.
WickySalsa Dec 14, 2013 @ 3:04am 
try uninstall (any)old driver before installing new one. I have this problem in the past where graphic driver stacking up and made many games performance worse. Also, check if your graphic card fan working properly. I use Gigabyte GTX670 and one wire get stuck in one of the fans. I can still play many games but performance is not what is use to. One day I experience hard crash while using internet and can't boot up my PC so I open PC case and find the culprit lol.
yaphes Dec 14, 2013 @ 3:08am 
Originally posted by Pokkuti:
try uninstall (any)old driver before installing new one. I have this problem in the past where graphic driver stacking up and made many games performance worse. Also, check if your graphic card fan working properly. I use Gigabyte GTX670 and one wire get stuck in one of the fans. I can still play many games but performance is not what is use to. One day I experience hard crash while using internet and can't boot up my PC so I open PC case and find the culprit lol.
Thanks very much, I'll check it out
Kourgette Dec 14, 2013 @ 6:58am 
Dude, it happened to me when I played Metro 2033 as well :( And it's doing it again with Alan Wake (And my PC is brand new)...
yaphes Dec 14, 2013 @ 5:34pm 
Originally posted by Kourgette:
Dude, it happened to me when I played Metro 2033 as well :( And it's doing it again with Alan Wake (And my PC is brand new)...

eh......well, I have given up ..= =
KoRos_1990 Dec 30, 2013 @ 10:27pm 
Originally posted by Plaid:
That's strange. I use GTX 660 (non-Ti) and get great performance, and that's with everything maxed out.

It sounds like you might be using a laptop and the game may not be using your preferred card.

I have a 780m and the game runs about 30 FPS on max on my laptop...but the strange thing is when I plug my laptop to an HDTV the FPS goes up to 60...I think it is because the laptop won't change to Nvidia...it is at Intergrated...
Showing 1-15 of 20 comments
< >
Per page: 15 30 50