Alan Wake > General Discussions > Topic Details
3l™ Jan 24 @ 2:48pm
Very slow game and i have a good computer. ALAN WAKE + DLC
Hi, my game is very slow and i dont understand why. I have a intel core i7 3770 3.4 GHz, a zotac GTX 650 TI AMP Edition 2gb, 8gb ram 2133 mhz, one SSD with 60gb plus one HDD with 1TB. I checked up in the web and this is more than enough to run the game properly. It have the latest GPU drivers. I was very cheap but im unhappy with this situation. Please someone reply to this or try to explain me.
Last edited by 3l™; Jan 24 @ 2:49pm
Showing 1-15 of 45 comments
< >
ACJCLIGHTNING Jan 24 @ 10:47pm 
well what FPS are you getting and what settings are you on?
Endgegner Jan 25 @ 12:28am 
How many FPS have you?
Octopus Jan 25 @ 2:47am 
I have the same problem.
3l™ Jan 25 @ 5:15am 
About FPS can't be sure because i don't really now how to check in this game. For the settings, i tried in almost every way possible, changing the resolution between 1920 to even 1024, and other options but allways had the same effect.
ACJCLIGHTNING Jan 25 @ 11:18am 
just use any fps monitoring program like fraps or something.
Fée Jan 30 @ 12:53am 
Also get a really bad framerate and my PC is actually stronger than yours!

I get around 50FPS at 720p on medium settings.

lol PCGW even says this is a good PC port, my ♥♥♥ it is!
Doktor Mandrake Jan 30 @ 9:27am 
Originally posted by Fée de la Mort:
Also get a really bad framerate and my PC is actually stronger than yours!

I get around 50FPS at 720p on medium settings.

lol PCGW even says this is a good PC port, my ♥♥♥ it is!

Works fine for me, and my system specs are weaker then both of yours I'm guessing lol

Windows 7 64bit
GTX 760
dual core i5 @3.20ghz
8gb ram @665mhz (shocking I know)

And on highest settings, with just AA and AF turned down just a tad, it runs at mostly 60fps but sometimes can go down to 50fps
3l™ Jan 30 @ 3:19pm 
Can't understand why :S
3l™ Jan 30 @ 3:21pm 
665mhz?
Brecor Jan 30 @ 3:39pm 
Had the same problem. Might have something to do with overheating? My FPS used to drop to single figures after a while. I find if I pause and go back to the game in a few minutes it goes back to normal and is playable.
3l™ Jan 30 @ 4:00pm 
Overheating i don't know, as soon i turn on computer, if i enter the game, it happens the same. maybe your problem was different from mine. Thanks for the reply Brecor.
Keysofsolomon33 Feb 18 @ 10:39pm 
I dont have any trouble running this game..
3l™ Feb 19 @ 2:33pm 
we do
BDK Feb 20 @ 6:18pm 
Try turning down SSAO and Volumetric lighting. With the latter turned all the way up my GPU gets more toasty than usual. Your 650 TI is in the middle of an old Radeon 5770-5830, aka not very good.

In other news, game plays butter smooth maxed out on my R9 270X @ 1080p.
­­Δ👽 Louna 👽Δ­­ Feb 23 @ 3:45am 
Was running perfectly fine on my old computer that had a GTX580. (Won't talk about my new GTX780ti 3-way SLI)

Your GPU is totally mid-serie. Which isn't that good. And you CPU shouldn't overheat ZOTAC tend to overheat too.

Showing 1-15 of 45 comments
< >
Per page: 15 30 50