sneezythesquid Jan 9, 2013 @ 6:32pm
Game Thinks I Don't Own It
For some reason, every time I try and play the game, instead of "Play" the button just says "Store" and takes me to the Days of Wonder webpage, which says that I already own the game. I've uninstalled it and deleted the local content several times, deleted the folders from the Steam Aps folder from my computer, but each time it's like I don't own the game.

It's really starting to get on my nerves.
Showing 1-7 of 7 comments
< >
CAPSMAN Jan 10, 2013 @ 2:31am 
I've been having the same problem.
matt Jan 14, 2013 @ 7:32am 
I found that I needed to have the Steam app open and launch if from there, as opposed to launching TTR from its own icon.
Apina Jan 14, 2013 @ 11:20am 
I had the same problem for 2-3 days last week, then it worked fine again until yesterday, but now it's happening again. Having steam app open or not doesn't make any difference.
chickenhobby Jan 21, 2013 @ 11:24am 
You may trying to play one of the games that provides 4 free plays, then asks or takes you to the "store" to buy the version you have been playing. This is different that the game you purchased. Ticket to Ride has a number of different versions. You can ONLY PLAY THE ONES YOU HAVE THE CODE(S) for INDEFINITELY. I had the same problem and sent an email to the support group at Ticket to Ride and they explained the situtation to me. They look up your history and will know exactly what you are talking about.
[HyperX'Liquid] DAC | cazaron Jan 21, 2013 @ 12:09pm 
While I'm not sure what chickenhobby is referring to with the indefinite playing, your best bet is definitely to email Days of Wonder through their site.
Last edited by [HyperX'Liquid] DAC | cazaron; Jan 21, 2013 @ 12:09pm
Darkm1nou Jun 29, 2013 @ 5:28pm 
Just to maad people know that this problem still happening, and it's really a shame that after more than 6 month the editor didn't tried to do anything to clear that, and force people to mail them each time it happen
Banankage A/S Aug 6, 2013 @ 12:44pm 
I am currently having the same problem. Does anyone found out how to fix it?
Showing 1-7 of 7 comments
< >
Per page: 15 30 50