Ticket to Ride

Ticket to Ride

View Stats:
Kin Dec 30, 2012 @ 7:56am
Can't play Online Games (Fixed)
Despite buying the complete pack, the system says that I do not own the game so I can't join any multiplayer games. I can, however, play all the maps on solo. Please help!

Edit: For some reason, it works now. I guess there's some delay when registering my game.
Last edited by Kin; Dec 30, 2012 @ 7:59am
< >
Showing 1-13 of 13 comments
Velisarius Dec 31, 2012 @ 1:30pm 
I am still having this problem...Any tips?
Kin Dec 31, 2012 @ 1:38pm 
Nope. Mine just started working after I made the post.
Nandri99 Jan 1, 2013 @ 2:04pm 
I have same problem !
Evann71 Jan 2, 2013 @ 11:53am 
same problem... i try online game and software says i'm offline, HELP
Xaegoth Jan 2, 2013 @ 2:31pm 
I can't join any multiplayer games (the button that says "join" is grayed out).

And when I try to play an online game through the play menu, I get an unknown Dexter or Alvin error.

I own over 100 Steam games, many of which have online components and I have NEVER had any issues playing online. Pretty frustratig since I bought this game to play online, not against CPU opponents.

Edit - OK, oddly enough, just restarting the game now allows me to play MP games. So for those people who can't play MP games, try restarting the game.
Last edited by Xaegoth; Jan 2, 2013 @ 2:34pm
vigulisam Jan 5, 2013 @ 5:43am 
Same problem, I bought full pack and now can play only solo games.. can anybody help me? any tips?
DAC | cazaron Jan 6, 2013 @ 1:37am 
Restart your game.

Make sure your Days of Wonder account works (log in on the webpage, do the 'connect with steam' prompt)

Go see the mechanic in the settings menu, click 'Edit my account details'.

If they all don't work, restart the game once more to be sure, then, I have no idea.

These have worked for all the people I've encountered with this issue.
Mr.Cortex.600 Mar 28, 2013 @ 6:49am 
Also i cant play online... in any game i suspend loading so what i do ???
Sergiostropovich Jul 1, 2014 @ 6:41am 
I can't play either. Today I tried to play straigh from Steam and did not recognised my login. I had to reset my DoW password to get in. Then it does not allow me to play online games, but neither alone. I had the complete set of TtR boardgames and now it seems I have none!!!
Sergiostropovich Jul 1, 2014 @ 8:50am 
Loged out steam, login after a while and fixed! :)
cherry_spagetti Feb 6 @ 6:59am 
I am having the same problem right now too :( please fix
Bahpu# Mar 22 @ 9:27am 
Guys, try to Defrag your pc.
Use defraggler.
It will take a very long time but it is worth the wait. My pc didnt load gmod but after a defrag it did! Even if it does not work your pc will be better.
Katsumoto Jun 4 @ 9:58am 
Originally posted by DAC | cazaron:
Restart your game.

Make sure your Days of Wonder account works (log in on the webpage, do the 'connect with steam' prompt)

Go see the mechanic in the settings menu, click 'Edit my account details'.

If they all don't work, restart the game once more to be sure, then, I have no idea.

These have worked for all the people I've encountered with this issue.

Sorry, but at milestones-web page there is no way for register...
...and what do you mean with "Steam-Promt" ???
...still no way to join multiplayer mode...
thx for help
< >
Showing 1-13 of 13 comments
Per page: 15 30 50