Waves > General Discussions > Topic Details
The Guy with The Hat Nov 1, 2013 @ 7:18am
Mouse/Keyboard Lag
I have been playing the Waves demo a lot recently, but I've been having a major problem: there is a lot of mouse/keyboard lag. Whenever I move the mouse, click a mouse button, or press a key on my keyboard it takes the game about 1/2 of a second to act on my input. This is incredibly annoying, and makes it difficult to kill/evade enemies before they kill me. Out of the ~100 times I have played cruch time, I have never died less than once per game, my highscore is a bit over 6,830,000, and 90% of my scores are below ~2,500,000. Other than this, though, Waves is a great game, and I'll definitely buy the full version if someone can tell me how to fix this lag.

Some additional information:
  • The mouse and keyboard lag is the only type of lag I get.
  • The mouse and keyboard lag only happens in Waves, not other games.
  • I am using Windows XP
  • I am using a microsoft intellipoint mouse.
Showing 1-4 of 4 comments
< >
Plaid Nov 1, 2013 @ 12:06pm 
Do you happen to have vsync enabled anywhere in your system?
I know this is kind of a "duh" question, but I've gotta ask.
RoX Nov 1, 2013 @ 4:29pm 
First, I highly recommend a 360 controller for this game. Second, it took me a couple of games to get this myself but if you are still "lagging", it could be that you haven't caught on to the physics yet. There is a reason that this game is called Waves, (in my opinion) because the mechanics are about "fluid" motion and can be very unforgiving if you are herky jerky with your control (i.e. moving from one direction, quickly to the exact opposite direction). To understand the physics of the game it helps to apply the Newton laws of motion. The time (force) it takes to move a round object in motion in the opposite direction could be your "lag". This is not Geometry Wars. Lasty, if none of that works for you, I recommend a new computer. Hope this helps, its a great game!
RoX Nov 1, 2013 @ 4:33pm 
Or like Plaid said, could be your graphics too. Turn them all to the lowest settings and see if that corrects the lag.
The Guy with The Hat Nov 2, 2013 @ 10:07am 
Originally posted by Plaid:
Do you happen to have vsync enabled anywhere in your system?
I know this is kind of a "duh" question, but I've gotta ask.
I haven't found any system setting for Vsync, but there is the ingame one. Changing that, however, doesn't appear to do anything.

Originally posted by Kaddy_Wompus:
First, I highly recommend a 360 controller for this game. Second, it took me a couple of games to get this myself but if you are still "lagging", it could be that you haven't caught on to the physics yet. There is a reason that this game is called Waves, (in my opinion) because the mechanics are about "fluid" motion and can be very unforgiving if you are herky jerky with your control (i.e. moving from one direction, quickly to the exact opposite direction). To understand the physics of the game it helps to apply the Newton laws of motion. The time (force) it takes to move a round object in motion in the opposite direction could be your "lag". This is not Geometry Wars. Lasty, if none of that works for you, I recommend a new computer. :D: Hope this helps, its a great game!
Or like Plaid said, could be your graphics too. Turn them all to the lowest settings and see if that corrects the lag.
I turned all the graphics settings down, and that mostly solved the problem.

Thanks to both of you for the replies!
Showing 1-4 of 4 comments
< >
Per page: 15 30 50