Arma 3 > Tweaking & Settings > Topic Details
Dwarden  [developer] Jul 13, 2013 @ 5:05pm
"-nologs" may improve performance, no stuttering
in case someone want to test solution to the problem of too spammy RPT file (report log)

try use commandline parameter in the STANBLE or DEV branch
-nologs

and tell us the results (in other words, we want Your feedback)

HOWTO:
in the STEAM's game list, select Arma 3 Beta, then right-mouse-button click to raise menu
> select Propterties > in General tab (first one already) > select Set Launch Options > type in there (w/o the quotation marks) "-nologs"

if you want multiple parameters then e.g. "-nosplash -nologs"

more params http://community.bistudio.com/wiki/Arma2:_Startup_Parameters#Available_parameters

original thread: http://forums.bistudio.com/showthread.php?159155-quot-nologs-quot-may-improve-performance-no-stuttering-read-details

p.s. be aware this means none errors saved to RPT file (report log)
so in case you want report some bug to Arma 3 feedback tracker http://feedback.arma3.com
then please disable this commandline param first

p.p.s.
we added TripleBuffering as experimental, we use special RT instead of usual back buffer
so the performance and visual differences shall be neglible
(we don't use plain double buffering, it's similar to DB with page flip but more closer to TB)

any build after 109519 you may try (dev branch)
tripleBuffering=1; //default is 0 , in arma3.cfg
and tell me
if it runs faster or cure sync issues (big screens, special resolutions, multi monitors etc)

... suggested to use with
GPU_MaxFramesAhead=1; //that's render frames ahead (flip queue size)
http://community.bistudio.com/wiki/arma2.cfg

for these who have 4=> GB memory is useful to use commandline
-maxmem=2047
Last edited by Dwarden; Sep 28, 2013 @ 1:53am
Showing 1-15 of 200 comments
< >
TreeTop ® Jul 13, 2013 @ 6:30pm 
can do

As tested no performance gains for me. 3770k 660ti standard settings
Last edited by TreeTop ®; Sep 9, 2013 @ 2:16pm
FishIsTwonk Jul 13, 2013 @ 7:06pm 
Danke
PostalVendingMachine Jul 15, 2013 @ 4:26am 
Tested it out while looking at Agia Marina, 98-105 FPS without -nologs, 102-110 FPS with -nologs. Worthwhile performance boost in my opinion. (Tested on GTX 670, I5 2500K @ 4.5GHz, SSD. Standard settings, SMAA ultra, PP sliders maxed, Nvidia settings on max performance)
Dwarden  [developer] Jul 15, 2013 @ 11:50am 
thx for feedback, forums shows that majority of users sees either performance or less jitter/stutter/lod flicker etc.
[UI] Phoenix Jul 15, 2013 @ 6:58pm 
Makes sense, considering the logs are just one more CPU bottleneck and right now thats the biggest performance issue with the game. I've got a 6-core Phenom 2 and 8-core FX both rated around 4.2 Ghz matched with HD 6970's and yet I can't get more than 20 fps in multiplayer (even very basic scenarios). Singleplayer seems alright in most scenarios, sitting around 40-50 fps. I'll try this and see if I get any improvements.
Batman Jul 15, 2013 @ 11:40pm 
Hmmm
Hakan_SDM Jul 16, 2013 @ 4:39am 
Will test this soon, seems legit
Axequit Jul 16, 2013 @ 6:07am 
same, hmmmm
[NSA] PoisonKris Jul 16, 2013 @ 2:00pm 
this game is so beautiful with the rite stuff :)
Qla Jul 17, 2013 @ 3:45pm 
This actually works?
KillCrit Jul 18, 2013 @ 5:21am 
Originally posted by Phoenix:
Makes sense, considering the logs are just one more CPU bottleneck and right now thats the biggest performance issue with the game. I've got a 6-core Phenom 2 and 8-core FX both rated around 4.2 Ghz matched with HD 6970's and yet I can't get more than 20 fps in multiplayer (even very basic scenarios). Singleplayer seems alright in most scenarios, sitting around 40-50 fps. I'll try this and see if I get any improvements.

is it yor cpu or is is your HD? :D
Constantine Jul 20, 2013 @ 10:49pm 
Originally posted by Zigzag:
Originally posted by Phoenix:
Makes sense, considering the logs are just one more CPU bottleneck and right now thats the biggest performance issue with the game. I've got a 6-core Phenom 2 and 8-core FX both rated around 4.2 Ghz matched with HD 6970's and yet I can't get more than 20 fps in multiplayer (even very basic scenarios). Singleplayer seems alright in most scenarios, sitting around 40-50 fps. I'll try this and see if I get any improvements.

is it yor cpu or is is your HD? :D

Games Cache to ram so...It's the CPU
Weedian Jul 25, 2013 @ 5:18am 
is this now appliable in stable version, with newest patch, or still in dev only?
Dwarden  [developer] Jul 25, 2013 @ 6:15am 
dev only
twitch.tv/donakuma Jul 29, 2013 @ 9:39am 
Es un buen juego
Showing 1-15 of 200 comments
< >
Per page: 15 30 50