Arma 3 > Trash bin > Topic Details
Sniper™ Mar 14, 2013 @ 3:41pm
FPS issues are linked to GPU, not CPU
A dev for ArmA 3 alpha commented on a thread about low FPS stating that low CPU utilization isn't the cause of low FPS in ArmA 3. I completely agree however he failed to mention anything about low GPU utilization. For some (I think most), ArmA 3 only utilizes ~40% of their GPU which is most certaintly the direct cause of low FPS. I would love for the devs to adress THIS issue rather than the low CPU usage.

If my GPU was being taxed 99% and I still got low FPS, I'd have no problems and accept it. However it should be using 99% rather than 40%.
Showing 1-9 of 9 comments
< >
Sir Topem Keks Mar 14, 2013 @ 3:44pm 
This, at least when i tested, Cannot be true. As I increased settings, GPU usage went lower and my CPU usage went up while my FPS just dropped. As i decreased settings, GPU usage went up (to 70-90%) and my FPS skyrocked to 50-60 FPS and 45 in the infantry showcase town. The FPS issue most definitely stems from CPU utilization and how the game is CPU heavy does not help.
Kypho Mar 14, 2013 @ 3:58pm 
Running fine on my GT440 - AMD 8120, 8gb ram, no lag
Nya` Mar 14, 2013 @ 4:03pm 
It's not related to the GPU's at all, the second you remove any AI/objects from the game world the GPU usage goes through the roof. I get like 70-90 FPS on the editor with nothing spawned in the world but me. If i'm actually playing the game though with anything in the world GPU usage tanks. Obviously things being calculated in the game world are handled by the CPU thus the limitation is not GPU related, it's not even hardware related at all, it's the engine software.
Sniper™ Mar 14, 2013 @ 4:07pm 
Originally posted by deuce:
it's not even hardware related at all, it's the engine software.

Obviously it's not hardware related. I never sait it was
Prodigy Mar 24, 2013 @ 12:54pm 
Sniper is totally right here. I have a Intel i7 3770k @ 3.5 ghz and a 7950 DD OC edition which should be more than anough to play arma 3. But it only uses 20% to 50% of my graphicscard. The low gpu usage is causing me lag. Play with 25fps to 58fps with an avg. fps of 39

They really need to fix this! =)
Nya` Mar 24, 2013 @ 1:59pm 
Low GPU usage is caused by lack of the CPU being properly utilized....
LuftWaffle Mar 28, 2013 @ 6:46pm 
No this can not be true. I have a 7950, and a decent CPU at 3.2 GHz. I'm currently at 30 fps...
Saetia May 5, 2013 @ 10:58am 
It's a horrible engine, nothing more.
Last edited by Saetia; May 5, 2013 @ 10:58am
Addiction Jul 10, 2013 @ 12:31am 
This subject is not true, please refer to the battleguns website where they go fully in to detail about this. http://battleguns.net/forum/m/7737561/viewthread/6153624-arma-3-low-fps-cpu-optimization-fix
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Mar 14, 2013 @ 3:41pm
Posts: 9