Arma 3 > Troubleshooting > Topic Details
Prinsworth Mar 5, 2013 @ 8:56am
"ArmA3 has stopped working" Crash on launch (Possible) FIX!
This may or may not work. But this fixed it for me.
The games first time setup of DirectX fails, resulting in this problem.

1. Go to your Arma 3 DirectX directory. (C:\Program Files (x86)\Steam\steamapps\common\Arma 3\DirectX)*

2. Run DXSETUP.EXE

3. Once installed it should launch correctly.

Even if you have the latest DirectX .etc installed. I do too, but this fixed it.
Showing 1-14 of 14 comments
< >
YTDamnit Mar 5, 2013 @ 9:21am 
Worked for me.
Fuusko Mar 5, 2013 @ 11:21am 
I have the same problem but this did not fix it for me :(( Any other solutions??
Prinsworth Mar 5, 2013 @ 11:36am 
Originally posted by Fuusko:
I have the same problem but this did not fix it for me :(( Any other solutions??
Other things you can try is to Right click the game in your library and navigate to properties and then "Verify integrity of game cache". Along with updating your Graphics Drivers.
Fuusko Mar 5, 2013 @ 11:46am 
Tried to verify the game cache, also chose "let 3d application decide" on nvidia settings and I have the latest drivers. Still doesn't work.
Prinsworth Mar 5, 2013 @ 11:49am 
Originally posted by Fuusko:
Tried to verify the game cache, also chose "let 3d application decide" on nvidia settings and I have the latest drivers. Still doesn't work.
Looking through other posts there are reports of the latest Nvidea drivers not being Arma 3 friendly. Some reccomend to rollback. But some have also found a fix by uninstalling the program "ZoneAlarm". A qoute from another user "NVIDIA USERS: If you are using 314.07, roll back or use the beta drivers! 314.07 is causing problems everywhere!". I use an ATI card so i would not be able to help there.
Fuusko Mar 5, 2013 @ 11:51am 
I am not using Zonealarm but I will try to roll back on the drivers, thank you.
Fuusko Mar 5, 2013 @ 11:59am 
Still not working.. :(((

Edit: Also tried to switch off SLI, did not help. Tried both previous WHQL and BETA drivers.
Last edited by Fuusko; Mar 5, 2013 @ 12:08pm
Omelette Mar 5, 2013 @ 5:20pm 
I tried to install the direct x thing in the folder installation folder and it wont finish installing so please help
hockey_demon666 Mar 5, 2013 @ 5:57pm 
Tried all the above. no go
GaNjAlF 3ö~ Mar 6, 2013 @ 5:37pm 
tried the direc x thing.....change the drivers for my video card (grx 670). I still crash most every time.
I always crash after I choose a character and when I can play after 10-15 min arma3 just crash.
Cobryn Mar 7, 2013 @ 1:52am 
@Prinny: Big thx to you, man. Worked fine. I was a little bit worried about it when I got this error message. First tried to verify via Steam - no effect, then tried to solve it by executing this ZoneAlarm- solving issue - no effect, a new installation of DX downloaded from Microsoft didn't fix it either (*?*), the only thing that helped was installing these game-bounded DX Files. :D
Funny thing, but worked fine.
Cheers
Last edited by Cobryn; Mar 7, 2013 @ 1:52am
Dingo Mar 8, 2013 @ 11:15am 
Alpha splash screen appears then stops and disappears, a few seconds later message on taskbar says amd driver has stopped suddenly but recovered, have uninstalled drivers and reinstalled no joy, also in taskmanager windows 8 it show arma 3 alpha.exe runnning as a background prosess
NoodleMoose Mar 8, 2013 @ 7:14pm 
Same thing happens to me too
Luca May 18 @ 8:29am 
it doesnt work for me PLEASE HELP!! i cry myself to sleep because i cant play this game! ];
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Mar 5, 2013 @ 8:56am
Posts: 14