Arma 3 > Troubleshooting > Topic Details
Derpy Mar 23, 2013 @ 4:49pm
Massive lag after joining a server to the team-selection
Everything works fine, but when i connect to a server, i'm not able to click a team or the ok-button because of the lag. After clicking, it takes up to 30 seconds for my action to be noticed. With luck i can click the ok-button within the first 10 seconds (the lag strangly starts not in the first seconds...), so it starts directly and i'm in the game, but most times i got kicked of the server because of the delay. In the game, everything is fine then. No big lags, no delays.
Any ideas?
Showing 1-6 of 6 comments
< >
The Dirty Bubble Mar 24, 2013 @ 7:57am 
Same problem here
Relnor Mar 24, 2013 @ 8:17am 
This happens to me too. I take it by lag you mean the whole thing actually FREEZES completely and all you can do is wait ?

You can either press Esc and get taken back to the server browser, or wait, and after a bit you should get in, hopefully~.

It doesn't always happen though, sometimes I get through just fine, hard to tell why.
Last edited by Relnor; Mar 24, 2013 @ 8:17am
Derpy Mar 25, 2013 @ 5:16pm 
It seems to be connected to the number of players on the server. The more players are there, the bigger this delays get. If i got lucky and got in the game, no problems with delays most times.
Derpy Mar 28, 2013 @ 4:58pm 
Well i dont know what happend, but the bug is completly gone. Everything works fine since yesterday. Dont know why.
KG200_Ifestos1 May 3, 2013 @ 5:08pm 
Same problem i cant selection team to action!!! in servers!!
Last edited by KG200_Ifestos1; May 3, 2013 @ 5:21pm
cod--battlefield Jun 13, 2013 @ 2:13pm 
Hello everyone
I keep this brief, I have a decent gaming computer and I can play most games on full graphics but when it comes to arma 3 my fps drops dramatically. However I have found a solution that does not effect graphics, while DRAMATICALLY boosting performance.

Youtube this video:
Arma 3 fps/graphic performance FIX

or use the link:
http://www.youtube.com/watch?v=iZTXFvucBe0&feature=player_embedded

This little fix does not need to be done every time, but the video says it does.
This fix made my arma 3 go from low graphics and poor fps (arount 10) to Nearly MAX graphics at 40-60 fps.

Hope this helped the arma 3 gamers out there trying to fix there performance.
Cheers everyone.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Mar 23, 2013 @ 4:49pm
Posts: 6