Arma 3
Arma 3 > Troubleshooting > Topic Details
Bavaman Mar 7, 2014 @ 10:33am
Low FPS anyone?
Anyone with very low FPS on single and multiplayer?

Specs are Win8 64bit; i7 quad core 3.5mhz; GTX 660; 8gb Ram

Is it just me or the game is laggy as it can be?
< >
Showing 1-7 of 7 comments
lincolnlou Mar 8, 2014 @ 5:08pm 
ya man the game has massive issues i have GTX 545 with 16GB of Ram with a Beast of a I3. Its pretty stupid how i can play any game out there on the higehst settings but this one.... on MP i get around 30 FPS and lower but when i play by myself it can run from 30 FPS to 60 FPS... Its really weird cause i can have my settings on High and very high but even if i turn the settings on the lowest it can be the FPS still doesnt really change..... i must say its bull ♥♥♥♥ that i have had this game since beta release and its been a year and they havent fixed the FPS issue
Midnight Express Mar 9, 2014 @ 4:46pm 
i3 struggles with Arma 3 in Multi. My son has an i3, and even A2 would get choppy in big fights. Arma3 is the only game I ever saw an increase in performancein, when I went from my i5 to my i7. Arma 3 just loves CPU, Oh, and it doesnt run "great" nomatter what you have, and I run an i7 3770, and x2 gtx 680 SLI, so don't feel too bad : P
Last edited by Midnight Express; Mar 9, 2014 @ 4:48pm
ClayBrown (Eagle) Mar 12, 2014 @ 8:39pm 
I have a Dell Vostro 1500 a very very crappy computer and I run 10-15 in single and multiplayer. I canhave it on low 10-15 and on High 15-20. It makes no sence but it is still choppy so I need to get a new computer anyways. :)
TacticalSandals Mar 14, 2014 @ 9:22am 
the lag is probably server side not client side if you get good frames in your own lobbies/single player.
ClayBrown (Eagle) Mar 17, 2014 @ 3:03pm 
Might be but sometimes my single player is choppy.
TheDarkSide69 Apr 2, 2014 @ 7:28am 
ive got an fx8350 @4ghz 8 gb ram gtx 660 on atlis life i run at around 30fps but get bad spikes when someone comes near me but this is server side issues not mine as if you try breaking point mod or just play a normal co op mission im running at 60fps
DeSyncD Apr 14, 2014 @ 2:34pm 
Personally I have to say this is the first game I have ever encountered which plays better on ultra/high settings then compared to low. I have asked around and got the response it could be its just pushing more out of my GPU but how true this is I am not quite sure.

I do think the mods are just way to demanding. If I run Altis Life or Wasteland I sit at 20/25 but if it gets busy or even just 1 or 2 players about and things start to drop to under 10fps.

My rig is not amazing but when you consider I can play all of the AAA titles out lately without much problem on high/ultra settings it brings concerns as to why BIS just cannot seem to find a decent middle ground when it comes to graphics, map size etc and performance on rigs which are not running twin SLIs and the latest GPUs.

I get the feeling it could be time BIS stepped back and took a serious look at any new game they develop and maybe design to literally start from scratch because if you can't get a game which runs at 30fps without having a super rig you have some serious issues. You would probably also make more money as Arma is notorious for running badly on mods but also all round in comparison.

Anyways that is all I have to say. I am not a "hater" in fact I love Arma and the mods which have sprung off from it.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Arma 3 > Troubleshooting > Topic Details
Date Posted: Mar 7, 2014 @ 10:33am
Posts: 7