darkelf Jan 1, 2013 @ 2:38pm
[SOLVED] no sound on Linux
just bought SPAZ and installed on Linux - game works but there is no sound

EDIT - solved, I am on 64-bit system and lib32 alsa was missing, now it works
Last edited by darkelf; Jan 1, 2013 @ 2:55pm
Showing 1-15 of 67 comments
< >
instabilis Jan 1, 2013 @ 6:54pm 
Had the same problem on Fedora 17 64-bit, turned out I needed alsa-plugins-pulseaudio.i686
dblade Jan 2, 2013 @ 6:45pm 
I needed ia32-libs to fix this on Ubuntu 12.04 64bit
Linux-storma Jan 13, 2013 @ 12:38am 
I got this on Debian Wheezy, I already had ia32 installed but had to replace the shipped libopenal.so with local ones.
altralaser Feb 6, 2013 @ 6:16am 
Arch Linux:
Replacing the shipped openal.so with a link to /usr/lib/openal.so also did the trick for me.
wdna Feb 8, 2013 @ 2:27pm 
I'm having trouble doing so on fedora 18:
it's not a good idea to replace system libs.
anyone have suggestions what i'm missing? or how to debug this issue, i really want this to work. if it has it's own openal.so, it should know to use it instead the system one?

$ yum list installed *openal*
Installed Packages
openal-soft.i686 1.14-3.fc18 @fedora
openal-soft.x86_64 1.14-3.fc18 @fedora
wine-openal.i686 1.5.18-1.fc18 @fedora
wine-openal.x86_64 1.5.18-1.fc18 @fedora
$ yum list installed *pulseaudio*
Installed Package
alsa-plugins-pulseaudio.i686 1.0.26-2.fc18 @fedora
alsa-plugins-pulseaudio.x86_64 1.0.26-2.fc18 @fedora
pulseaudio.x86_64 2.1-5.fc18 @updates
pulseaudio-gdm-hooks.x86_64 2.1-5.fc18 @updates
pulseaudio-libs.i686 2.1-5.fc18 @updates
pulseaudio-libs.x86_64 2.1-5.fc18 @updates
pulseaudio-libs-glib2.i686 2.1-5.fc18 @updates
pulseaudio-libs-glib2.x86_64 2.1-5.fc18 @updates
pulseaudio-module-bluetooth.x86_64 2.1-5.fc18 @updates
pulseaudio-module-x11.x86_64 2.1-5.fc18 @updates
pulseaudio-utils.x86_64 2.1-5.fc18 @updates
wine-pulseaudio.i686 1.5.18-1.fc18 @fedora
wine-pulseaudio.x86_64 1.5.18-1.fc18 @fedora
mirkobern Feb 9, 2013 @ 12:19pm 
confirmed the problem, the shipped openal library doesn't work.

fedora 17 here

simply renamed the openal.so in the game and sobstiture with a link to the system one
"ln -s /usr/lib/libopenal.so.1 libopenal.so"
wdna Feb 16, 2013 @ 2:35pm 
I tried:

ln -s /usr/lib/libopenal.so.1 /usr/lib/libopenal.so

is that what you ment? did not work for me...
mirkobern Feb 16, 2013 @ 3:52pm 
Originally posted by Alkavan:
I tried:

ln -s /usr/lib/libopenal.so.1 /usr/lib/libopenal.so

is that what you ment? did not work for me...

not exactly,

i had gone into the steam installation, and in the directory

SteamLibrary/SteamApps/common/Space Pirates and Zombies

i renamed the file libopenal.so into libopenal.so-notworking

then in that directory I launched "ln -s /usr/lib/libopenal.so.1 libopenal.so"

this command create in local (steam) directory a link to the system library.

doing so i substituted the library shipped with steam with the system library that function
Last edited by mirkobern; Feb 16, 2013 @ 3:53pm
vulpix [Linux] Feb 17, 2013 @ 4:17am 
that worked. thanks!
Niwa Feb 18, 2013 @ 1:48am 
In my case, I had to "ln -s /usr/lib/i386-linux-gnu/libopenal.so.1 .local libopenal.so" in the game directory after installing ia32-libs on Ubuntu 12.04 64 bit.
boolf Feb 18, 2013 @ 4:21am 
I didn't even have a libopenal.so in my game directory but linking the system one worked like a charm. Thanks!
Niwa Feb 18, 2013 @ 5:40am 
Yes, I didn't have the libopenal library in my game directory either. Luckely I read mirkobern's post.
Last edited by Niwa; Feb 18, 2013 @ 6:51am
wdna Feb 18, 2013 @ 2:01pm 
Oh, FYI ...
It worked for me as well!
I also added comment on related issue i opened on github.
chemikerhero Feb 18, 2013 @ 2:19pm 
Since the last comments are a little inexact:
The following works: link (ln -s) your openal library to the following path:
"[Steampath]/SteamApps/common/Space Pirates and Zombies"
your openal lib can be found either in "/usr/lib/i386-linux-gnu/libopenal.so" (ubuntu as it seems to me) or in "/usr/lib/openal.so" (arch)
markov Feb 18, 2013 @ 2:35pm 
why is the symbolic link necessary? for some reason it worked however audio was working for me a day or two ago. tonight it stopped but the sym link worked
Showing 1-15 of 67 comments
< >
Per page: 15 30 50