Bastion > Technical Support > Topic Details
lazybee98 May 11, 2013 @ 10:47pm
Bastion does not run, Bastion has stopped working.
When ever i open it, it says Installing DirectX 9.0c (step one of one) Then it says bastion has stopped working Windows is searching for a solution to this problem.
Does anyone know how to fix this?
Showing 1-15 of 16 comments
< >
Scmnz Jun 8, 2013 @ 4:05pm 
sam problem, please someone tell me how to fix it, never finished it and want to play through the ending.
loki Jun 10, 2013 @ 2:39pm 
this is happening to me too and ive tried varifing the chashe and uninstalling/reinstalling it and neither of those worked.
Tatsur0 Jun 22, 2013 @ 3:13pm 
Many have resolved the problem by reinstalling Microsoft XNA Framework Redistributable 3.1[www.microsoft.com]

Hope that helps
Last edited by Tatsur0; Jun 22, 2013 @ 3:13pm
Scmnz Jun 25, 2013 @ 3:40pm 
Tried uninstalling the game and reinstalling it, and have tried

Originally posted by Tatsur0:
Many have resolved the problem by reinstalling Microsoft XNA Framework Redistributable 3.1[www.microsoft.com]

Hope that helps

nither worked for me. Have tried running game on two different computers, one running windows 7 and one computer runnng windows 8, it wont run either. please help. was really enjoying the story about a year ago when i was playing and it still ran correctly, and would like to play through the ending,
Tatsur0 Jun 25, 2013 @ 10:34pm 
Did you install any optional Windows Updates? Maybe try reverting if so?
shellhounds_summer_shard Sep 23, 2013 @ 5:10pm 
thanks sooo much tatsuro that fixed my game
Exhumed Oct 5, 2013 @ 2:25am 
Bastion does not run on my pc.

Message:
"No suitable graphics card found.
Unable to create the graphics device.
This program requires pixel shader 2.0 and vertex shader 1.1"

WTF!

All my other hundrets of games are running!

my pc spec:
Windows 7 x64
Intel Core 2 Duo E8400 (3GHz)
4 GB DDR2-800 ram
Geforce GTX 650Ti Boost 2GB ram
Last edited by Exhumed; Oct 5, 2013 @ 2:28am
Bad_Conduct Oct 5, 2013 @ 8:09am 
Originally posted by Exhumed:
Bastion does not run on my pc.

Message:
"No suitable graphics card found.
Unable to create the graphics device.
This program requires pixel shader 2.0 and vertex shader 1.1"

WTF! :chainsaw:

All my other hundrets of games are running!

my pc spec:
Windows 7 x64
Intel Core 2 Duo E8400 (3GHz)
4 GB DDR2-800 ram
Geforce GTX 650Ti Boost 2GB ram

Bad or wrong drivers, update your video card driver from Nvidia's website
Exhumed Oct 5, 2013 @ 8:27am 
Originally posted by Bad_Conduct:
Originally posted by Exhumed:
Bastion does not run on my pc.

Message:
"No suitable graphics card found.
Unable to create the graphics device.
This program requires pixel shader 2.0 and vertex shader 1.1"

WTF!

All my other hundrets of games are running!

my pc spec:
Windows 7 x64
Intel Core 2 Duo E8400 (3GHz)
4 GB DDR2-800 ram
Geforce GTX 650Ti Boost 2GB ram

Bad or wrong drivers, update your video card driver from Nvidia's website
Yes i updated nvidia drivers and i have the same problem again. my drivers are up to date.
Only "Bastion" and "Deadlight" not working for me!
Colonel Patches Oct 5, 2013 @ 8:32am 
I cant even get an error. I see it running, but it wont display.
Bad_Conduct Oct 5, 2013 @ 8:38am 
Originally posted by Exhumed:
Originally posted by Bad_Conduct:

Bad or wrong drivers, update your video card driver from Nvidia's website
Yes i updated nvidia drivers and i have the same problem again. my drivers are up to date.
Only "Bastion" and "Deadlight" not working for me!

You should create a new thread instead of hijacking one with a diff issue.
Pyrodox Oct 13, 2013 @ 5:44am 
I have been battleing with this problem for months and finally I have found a solution that works for me. I went into contol panel, clicked on Programs, Turn windows features on and off. In this menu I scrolled down and saw Microsoft.net Framework thing was unticked. I ticked this and then clicked on the little plus next to it. In there was two more things I ticked (The 2 win communications). I then clicked Ok and waited, it takes a while. I then restarted my computer and loaded up Steam. Started Bastion and it worked!
[SOA] Shotgunrain Oct 13, 2013 @ 10:07am 
try right clicking the game scrolling to properties, click that then got to local files and click verify game cache and that may fix it.
DNMMRDR Oct 14, 2013 @ 11:40am 
I did what Pyrodox did and this also fixed my installation.
Rory Dec 21, 2013 @ 2:12pm 
I had the exact problem described in the OP, and I was able to fix it by going to the Bastion folder in Program Files\Steam\steamapps\common\Bastion and running "xnafx31_redist.msi". I bought Bastion a while ago, but had uninstalled it for several months. During that time, I must have uninstalled the Microsoft XNA Framework, which "xnafx31_redist.msi" installs. For some reason, when I launched the game through Steam, it didn't pick up on the fact that I didn't have it. After installing it, everything ran correctly.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50