Bastion > Technical Support > Topic Details
Thurman Merman Feb 20 @ 6:53pm
Thumb buttons on linux version
Hey,

I was just trying to enjoy this game on linux for the first time. Now the problem is that I can't really bind my keys to where I would like them to be. I usually make good use of the thumb buttons on my mouse for things like interact and special powers or what you have. Problem is I can't for the life of me bind any of aforementioned keys to the side buttons.

I have a Logitech G400 mouse.

I tried imwheel. I tried xbindkeys and xte together. I tried esoterical xmodmap stuff and related ♥♥♥♥ that goes into xorg.conf.d. Nothing helped. So I have to assume this is a problem related to the mono .net impementation this game's using. Because those programs work just fine with other linux games on steam.

xev shows the buttons in question are 8 and 9 for back and forward. They work like advertised under firefox for example.

I would be grateful if someone could help me out or just clarify where the problem lies.

Thanks in advance.