View Stats:
Bastion > Technical Support > Topic Details
6lancmange Feb 17, 2014 @ 12:08pm
Graphics look like datamosh, making game unplayable
I have the demo installed and I also have the full game which I haven't installed. At first, it looks normal, when the company logos and such are shown, but as soon as it enters the main menu, the chaos happens. Everything is made up of sort of broken textures, everything apart the floating Kid and the scroll at the top, text also looks normal, but it doesn't look like it's what's supposed to say. For example, the text on the scroll says "GameStartScreenTitle", and when I press Story, the description says "New Game has no description. Lorem ipsum..." and so on. At first I thought that maybe when I start the game, it might look normal, but it doesn't. The Kid looks normal when he's not moving, everything else is just a big mess of more or less random textures and pixels. However, when I exit the game, the goodbye screen looks okay, save for the "Trial_Text" stuff. Also, when I was switching between the forum and the game, at some point there was an error that made me exit the application. Unfortunately, I can't take any screenshots because I'm starting the game from the folder it's in and not from Steam - when I bought the full game, the demo disappeared from the library. The print screen key doesn't work either, there's just a white screen. I guess I could later try taking a picture with my phone.

Now, technical stuff - my laptop passes all the requirements. My graphics card is ATI Mobility Radeon X1400, and I can't find any drivers newer than the ones I've got. According to the automatic downloader on AMD's website, they're up to date. So the only problem with that is that the company got sold and they stopped supporting this card. I really don't know what to do, I hope there is something that can fix this issue.
Last edited by 6lancmange; Feb 17, 2014 @ 12:16pm
< >
Showing 1-6 of 6 comments
troylights Feb 18, 2014 @ 11:00am 
Operating system? I've run this game with integrated Radeon graphics under Windows 7 and Linux Mint. The game seems a bit slow under Linux, but it works. Maybe you need to allocate more RAM to your video card in your computer's BIOS?
6lancmange Feb 18, 2014 @ 3:21pm 
Windows 7. I don't want to mess with BIOS unless there's absolutely nothing else that would work. Is there a less "hardcore" way to try to do that? Also, I'm kinda worried about the idea, and anyway, are the graphics really that demanding? I mean my laptop can run some other games with no problem and I've never had a problem like this with any other application. (like Sims 3 work even on high quality settings, although the laptop gets really hot really quickly, so I don't use those settings)
troylights Feb 19, 2014 @ 6:25am 
On the same laptop I play Bastion, I've also played Portal without problems. Portal 2 was a bit slow on the framerate, but still playable. I use a better laptop to play higher end games like Max Payne 3. I wonder if you can make some changes via the AMD Vision Control Center? I hope you can figure out a way to get it to work because it's really a fun game to play.
6lancmange Feb 19, 2014 @ 1:40pm 
I asked my dad about the BIOS settings and he said it's not even possible to do because it's a business laptop blahblahblah, it's a Thinkpad T60. I might try to do something with this AMD Vision Engine Control Center when I get back on my laptop, but I don't think it's gonna help 'cause AMD doesn't support these older ATI cards (it wasn't that long ago, come on!) and it might not recognise it. Anyone has any other ideas or had the same problem?
_wilco Feb 20, 2014 @ 6:31am 
If it's this Notebook: , I'm afraid it's not good enough to run Bastion. The wiki says the ATI X1400 has 128MB memory while Bastion needs 512MB. The GPU could eventually use System memory through HyperMemory to up it to 512MB, but considering that Bastion needs 2GB of memory, there's probably not enough for the GPU to use. How much system memory do you have(standard seems to be 512MB or 1024MB)? The T60 can be upgraded to 4GB. So this is the place, where you can make it work eventually.

But honestly, get something new if you intend to play games, that thing's 7 years old. That's just too old, sorry...
6lancmange Mar 1, 2014 @ 1:29pm 
Nah, that's not it, I checked the system requirements. If this had been the problem, I wouldn't have asked, but the thing is that my laptop should be good enough. It is the one you found, but it has some upgrades or something, I checked just to be sure and this is how it compares to the requirements:
Processor: Intel(R) Core(TM)2 CPU T5600 @ 1.83GHz (2 CPUs), ~1.8GHz (required is 1.7 GHz Dual Core or Greater)
Memory: 4096MB RAM (requires 2 GB)
as for the graphics card, I'm not sure which memory we're talking about so I copied all three that are listed there:
Display Memory: 1405 MB
Dedicated Memory: 126 MB
Shared Memory: 1279 MB

I think this computer can still run a thing or two, though of course, I'll seriously consider buying something better as soon as I finally start making millions.
< >
Showing 1-6 of 6 comments
Per page: 15 30 50

Bastion > Technical Support > Topic Details