Bastion > General Discussions > Topic Details
Amerika Feb 2, 2013 @ 5:30am
Linux Bastion - Will not install
Bastion shows up in my list of games I own that have Linux support but when I go to install it nothing gets downloaded and Steam makes it appear as if it's installed. Then, naturally, if I try to launch it I get a message stating that the game executable is missing.

Is the Steam/Linux version of this game simply not supported yet despite being in the list or is there something I need to do to fix this?
Showing 1-15 of 29 comments
< >
fabrice79 Feb 2, 2013 @ 7:33am 
Same for me, maybe they're still testing...
Meow Feb 2, 2013 @ 11:16am 
yeah same here I wonder if it's a permissions issue?
Amerika Feb 2, 2013 @ 11:31am 
Originally posted by Meow:
yeah same here I wonder if it's a permissions issue?

I think it's just borked is all. I can install anything else...just not Bastion.
Amerika Feb 2, 2013 @ 11:48am 
Interesting. There was a new update today that fixed some installation issues but didn't really seem to address Bastion. I went to go install Bastion again just in case and this time when I tried the install it asked me where to install to. I chose where I wanted to install but then it did the same thing as last night.
Pheonix Darkstorm Feb 2, 2013 @ 1:51pm 
Same here. just tried to install and second later it says its installed. ive tried verifying the game cache and it says all is fine.
eviljoel Feb 2, 2013 @ 7:05pm 
Note that it is not in the Linux store yet.
iamthefritch Feb 3, 2013 @ 1:02am 
it showed up for me too but the only thing it downloaded is the soundtrack so my guess is that its just the soundtrack it downloads and not the game kind of misleading but its interesting you can at least download the soundtrack
Nognir Feb 3, 2013 @ 7:04am 
It's the same deal as with Cave Story+, only downloading the data files. My guess is that it's being prepared for availability when Steam for Linux is out of beta.
Nexoose Feb 3, 2013 @ 9:00am 
same here, i'm also having the same problem with VVVVV and Cave Story :<
Sith Feb 3, 2013 @ 10:51am 
You're having this problem because there is a Linux version, but it's under a password protected beta.
So if you don't have access to that beta you won't be able to download/play the game, which will cause you to get a "missing executable" error.

Anyway, I just can't get why they are taking all this time to make steam-supported games that are already been ported for linux (in fact you can download/play bastion through USC, or the DRM-free HumbleBundle edition, without a problem, and the same is for other games like Snapshot, Closure, etc).
capcavern Feb 3, 2013 @ 5:41pm 
Alsmost all the humble bundle linux games had their "install" option removed and not included into the new "linux" categorie. Shank,bastion,cave Story don't install and only TeamFortress does. It's ok it's still a Beta. Don't forget that just few month ago the beta was only open to a restricted number of people. Wine will help us be patient.
Last edited by capcavern; Feb 3, 2013 @ 5:42pm
Amerika Feb 3, 2013 @ 5:43pm 
Ok, I'm cool if it's still in Beta and simply not ready. I was just making sure there was not a legit problem I needed to troubleshoot or report properly.
rudeboyskunk Feb 5, 2013 @ 6:02am 
Developer, could you please let us know when the full Linux version will be available????
grox Feb 10, 2013 @ 5:24am 
same problem
manolo.texaco Feb 10, 2013 @ 1:52pm 
same here
Showing 1-15 of 29 comments
< >
Per page: 15 30 50
Date Posted: Feb 2, 2013 @ 5:30am
Posts: 29