Dorfdad Jul 21, 2013 @ 6:58pm
360 controller not working
bought druing summer sale but sadly it doesnt work with 360 controller even though it has controller support legacy in menus. When I do this all I can do is jump. cant aim or do anything else. Anyone else have this issues and know a fix also whats the default bindings?
Showing 1-15 of 58 comments
< >
p0rk1ns  [developer] Jul 21, 2013 @ 11:57pm 
Hi Dorfdad,

Thanks for picking up PixelJunk Eden! Let's see if we can get your 360 issue sorted.

I know this is basic, but before we dive into everything please confirm that you're controller is working in other games or in Windows. You can check if all the inputs are working correctly from the Windows control panel. Just wanna make sure there isn't an issue with drivers.

I'm going to assume that everything is cool on that end and explain how enabling the controller should work in Eden. Let me know if there are any discrepancies. (This is from mouse mode)

- From the "Click to start" title, press Esc to get into the menu
- Go to controls
- Select Legacdy mode. The "bar" should be full when you've enabled it
- Hit esc again. The screen should fade out as the controls change over.
- Your mouse cursor should disappear now and you can control your grimp with the 360.

The default buttons are

Jump/Spin - 1 / A
Reel-in silk/drop - 3 / X
Quick warp - 4 / Y
Open menu - 8 / Start
Confirm - 1 / A
Cancel - 2 / B

When you first start the game, you won't have access to the quick warp or the drop attack initially. But you'll be to aim with the left analog stick (not the digital pad) and jump with the A button.

Let me know if any of this helps and if not we'll dig deeper!

Dorfdad Jul 22, 2013 @ 3:33pm 
Thanks for getting back to me, sadly that is what I have been doing for about 2 hours and gave up. Controller works fine playing other games without issue. Deleted local contents re-downloaded and still happens. I can select Legacy and it does reset but all I can do is jump. I can not AIM with analog or buttons. So my character pops left untill it can no more.

Im running windows 8 x64 tried in comptability mode also but no luck.

Hope you can figure this out. Looks great but im kinda bummed. This is a new windows 8 build also not like its full of crap..
p0rk1ns  [developer] Jul 22, 2013 @ 6:06pm 
Hi Dorfdad, (Ebeccarayray - I'm assuming since you hid your post the problem is resolved with you?)


Hmmm, that does sound strange. I know this sounds silly, but can you confirm that when you move the left analog stick you don't see a "line"? Check out my screenshot here and you can see the lil lines coming off my grimp - http://steamcommunity.com/id/p0rk1ns/screenshot/594757599086586659

Also, are you using a wired or wireless 360 pad?
Last edited by p0rk1ns; Jul 22, 2013 @ 6:09pm
Dorfdad Jul 22, 2013 @ 6:31pm 
wireless 360 reciver all other games work and yes i do see the line but it doesnt move

p0rk1ns  [developer] Jul 22, 2013 @ 7:27pm 
Interesting. You should be able to adjust that line - that's the angle of your jump - with the left analog stick. Moving the stick and pressing the default jump button (A, I believe) will move your grimp.

It seems like there is some input coming from the left analog stick, otherwise you wouldn't be getting the line. Here are a couple more things you could try:

- I know you've said it's working in other games, but you might want to try calibrating the joystick in Windows 8.

- Eden is a 32bit application and was ported in a WinXP environment. There shouldn't be any issues with 64bit OS - I run it on 64bit Win7 all the time - but you could try to change the compatibility mode to WinXP SP3.

Dorfdad Jul 22, 2013 @ 7:45pm 
Nah nothing works.. Not sure why this one game wont work i guess I will have to give up on this one
p0rk1ns  [developer] Jul 22, 2013 @ 7:50pm 
Arrgh, this is frustrating!

When worst comes to worst, you can play with the mouse, which is much better imho. Just so we're sure that the game is actually working correctly outside of this controller issue, have you tried to move the grimp around with the mouse?
Last edited by p0rk1ns; Jul 22, 2013 @ 7:52pm
Dorfdad Jul 23, 2013 @ 6:10pm 
Yeah mouse works fine.. PLayed a level like that already. Hard for me cause im on comfy couch...
p0rk1ns  [developer] Jul 23, 2013 @ 6:25pm 
Yeah, that's totally understandable. Big Picture Mode FTW.

This is the first time we've heard about this problem, so we're generally intrigued over here. As I said before, if there is a jump line coming from the grimp the game is receiving an input from somewhere. I'd really like to know if this is endemic to a problem with 64bit Win8 with Eden so we can fix it for everyone.

To make sure we've covered all bases (and it sounds like you have):

Have you tried any other controllers?
Are the drivers for the 360 controller up to date?
Have you tried a different USB port?
Dorfdad Jul 23, 2013 @ 6:34pm 
Yea tried last night a wired 360 controller same thing. I't like the D-pad and the analong are not functioning at all. Drivers updated. Ill try a different port right now.
Dorfdad Jul 23, 2013 @ 6:39pm 
just a follow up. Plugged into different port and same results.. Only keys that work ar A to jump (only goes left) and B which brings up the menu (I cant move up or down though)
Dorfdad Jul 23, 2013 @ 6:45pm 
Ok sorry to spam, but I figured it out.. Now can you fix it :) The problem is Blue Tooth Adapters.. When I have it enabled it doesnt work. DIsable it and it works fine!

Using a Bestbuy Rocketfish Bluetooth adapter and have it paired up to a Wii Mote.. if that helps explain anything??
p0rk1ns  [developer] Jul 23, 2013 @ 10:14pm 
Hallelujah! Okay, this is great info. I'll pass it along and hopefully we can get a hotfix put in. Many thanks!!
Arbor Day Jul 25, 2013 @ 4:02am 
p0rk1ns, you're amazing. I didn't need to read this thread (I don't even own the game on PC, and my PS3 is missing) but I clicked for whatever reason. I honestly didn't even know it had a PC release until I saw someone on my list playing it, I'll have to pick it up soon.

Developers who take the time to answer things as you do can be rare, and it's awesome to see some of you guys do it with such professionalism and finesse.
Last edited by Arbor Day; Jul 25, 2013 @ 4:04am
Shadow Enz Jul 26, 2013 @ 2:27am 
Yet another reason to love Q Games! I keep throwing my money at the computer screen so that Q Games can continue being funded but the money just bounces off the screen.

Guess I'll just wait 'till PixelJunk Monsters for Vita to throw some money towards Q Games, and hoepfully when more Q Games release for steam!

Also, what a fun idea to join on trading cards! I look forward to getting my Eden badge.
Showing 1-15 of 58 comments
< >
Per page: 15 30 50