Age of Empires Online

Age of Empires Online

View Stats:
+Durazell- Jul 21, 2013 @ 6:45pm
Problems starting the game.
Hello fellow members, I have a problem with this game. I have tried to reinstall and downloaded it, however, whenever I press ¨play¨ button nothing happens. Can it have something to do with my computer or is it a software problem with microsoft?
< >
Showing 1-8 of 8 comments
CreatorOfSomething Jul 22, 2013 @ 5:38am 
I got same problem D:
LundA Jul 22, 2013 @ 6:07am 
same here....seems like its some kinda bugg in steam :S (any admin or supporter who can help out?)
amicofrank Jul 22, 2013 @ 6:08am 
I've got the same problem, when I press "play" the window get closed and nothing happens. I've downloaded the game yesterday
TenJou Jul 22, 2013 @ 8:13am 
Yea i got the same problem the game dont start after i download it!
Garmonbozia81 Jul 22, 2013 @ 11:07am 
I suggest you uninstall GfWL and reinstall the Games for Windows Live Client, which you can find here: http://www.xbox.com/en-US/LIVE/PC/DownloadClient
Please try running the client without the game installed.
You should also download the Windows Live ID Sign-in Assistant to help sign in to GfWL: http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=15106
+Durazell- Jul 22, 2013 @ 2:08pm 
Thank you for the help, It worked ;)
LundA Jul 23, 2013 @ 2:51am 
is that help only for Xbox or wha does it meen?....i got my game on PC but it maybe dosent matter?
CreatorOfSomething Jul 31, 2013 @ 1:19pm 
Garmonbozia81 it didnt work for me i got in pc
< >
Showing 1-8 of 8 comments
Per page: 15 30 50