Quicker Jul 20, 2013 @ 9:22am
Can't get the bundle to work
I just bought the pro civ bundle. It downloaded and is in my DLC; however, I can't get it to actually unlock the 3 new civs when I'm in game. Does anyone have any suggestions to help me unlock the content I just bought?
Showing 1-15 of 17 comments
< >
The Woodsman Jul 20, 2013 @ 9:55pm 
Having this exact same issue, with the exact same bundle...i tried everything, even uninstalled and reinstalled Steam and the game...it's ♥♥♥♥♥♥♥♥ that we are even paying 15$ for a game no longer being supported. Nevermind for ♥♥♥♥ that doesn't even work XD
The Woodsman Jul 20, 2013 @ 10:35pm 
I also bought the domination package which isn't working either
alexcapo2 Jul 20, 2013 @ 11:54pm 
I'm having this problem as well. Ireland
talish Jul 21, 2013 @ 6:33am 
I am also having the same problem for the domination pack from steam, it show's up in steam but i cannot find a Key offered by steam to link it with the xbox live account

any help would be greatly appreciated

Thanks
PlaNetHeMp Jul 21, 2013 @ 6:42am 
I am also having the same problem for the domination pack from steam, i bouht, it shows up in steam but didnt change anything in the game. Im from Brazil
Last edited by PlaNetHeMp; Jul 21, 2013 @ 6:43am
Salty Taters Jul 21, 2013 @ 8:38am 
Hi, I am also having the exact same problem, have verified etc but nothing ingame, even though it's on the DLC tab. I'm in England.
Last edited by Salty Taters; Jul 21, 2013 @ 8:38am
Peter Jennings wannabe Jul 21, 2013 @ 9:19am 
Well, im having the same problem too. Tried everything.
Revleft Jul 21, 2013 @ 9:22am 
Same with me. I live in USA. Anyone can help me?
Garmonbozia81 Jul 21, 2013 @ 10:19am 
If you are experiencing this issue, please submit a support ticket, making sure to respond to the automatic reply if none of the solutions apply to your problem: http://ageofempiresonline.com/en/support_ticket
Garmonbozia81 Jul 21, 2013 @ 10:46am 
Update: Switching servers appears to make the content show up in-game. Please try if this works for you and submit a ticket otherwise.
Salty Taters Jul 21, 2013 @ 10:50am 
Hasn't worked for me at all.
PlaNetHeMp Jul 21, 2013 @ 12:06pm 
Hasnt worked for me...
The Woodsman Jul 21, 2013 @ 12:17pm 
It's not switching servers, it's transfering empires, just unlocked both of my packages by doing this! I highly recommend transering the empire to another server, if you like you can transfer it back afterwars
Salty Taters Jul 21, 2013 @ 12:19pm 
I tried transferring empires as well and still didn't work.
Quicker Jul 21, 2013 @ 8:24pm 
I transferred my empire and the 3 new civs were unlocked for me. Thanks Garmonbozia81!
Showing 1-15 of 17 comments
< >
Per page: 15 30 50