Shank 2 > General Discussions > Topic Details
typemakeR Dec 9, 2012 @ 9:46am
Shank 2 & Shank not starting on Windows 8
Hi, I already have Mark of the Ninja and love it. It works fine on my laptop.

I recently purchased Shank & Shank 2, but neither of them seems to work.
Shank just doesn't start. - In the log files I found the error "No valid display modes"

Shank 2 crashes before opening with the error "Shank 2 has stopped working"

I've tried reinstalling, verifying, checking drivers etc. - I'm guessing it has something to do with my graphics card and resolution (9400m, 1280x800), as Mark of the Ninja also defaults to windowed mode on my pc and won't go into fullscreen (the option is greyed out there too).

Is there the possibility to patch Shank 1 & 2 so they also default to windowed?
I'm fine with that - as long as I can play the games I've bought.

Hope the developers read this - I'm thankful for any suggestions how to fix this.

PS.: This seems to be a common error... but the default steam forums are down - so I'm posting it here.
Showing 1-13 of 13 comments
< >
WictorT Dec 9, 2012 @ 9:48am 
Try start on compatibility mode with win7 .
typemakeR Dec 9, 2012 @ 10:04am 
Tried that, same errors on both games. Also tried all other compatibility modes. I'm running Windows 8 64 bit. Tried forcing windowed through -windowed in Launch Options too - no dice. Not starting.
メ Toxic Dec 9, 2012 @ 11:38am 
in my windows 8, the game starting normally... my windows 8 is 64 bit
typemakeR Dec 10, 2012 @ 6:14am 
Are you running it on a laptop? I'm running it on a Macbook 13,3" in Bootcamp. I'm guessing as Mark of the Ninja will only start in windowed mode it has something to do with my screen size and resolution. - Just trying to reconfirm if somebody else is having the same problems and/or a solution for it.
joddd_man Feb 20, 2013 @ 11:55am 
i'm in the exact same situation, unable to play Shank 2 under bootcamp, and I'd really like a solution from Steam on this
Dead Cavalari Jun 30, 2013 @ 4:44pm 
Any news on this? I just bought Shank and have same issue.
Windows 8 64;
Geforce GTX 660 Ti, updated drivers
1920x1080 60Hz
typemakeR Jul 1, 2013 @ 10:45am 
I didn't find a solution after trying for hours. I kinda gave up on the games. :/ But I would be really happy if someone stumbled over a fix and posted it here.
Fÿyrio Jul 12, 2013 @ 7:00pm 
I have the same problem, but someone sayd that could be an issue with the directx. The sugest is the download of directx by this link:
http://www.microsoft.com/en-us/downl...ils.aspx?id=35
I´m still downloading, but looks like that is it
Dead Cavalari Jul 12, 2013 @ 8:39pm 
Thanks, It worked perfectly for me. Just downloaded, installed and everything worked.
Bowel Blaster 2000 Dec 17, 2013 @ 12:28pm 
On Win7, Shank 2 works beautifully, on Linux it works best with a ps3 controller as the 360 controller default settings are in poor taste & no vibration/configuration enabled!
On Linux Shank works perfectly with 360 controller & controller vibration IS enabled by default! However on Windows 7 & 8 it simply freezes during intro!

Kppqju77 Jan 5 @ 2:28am 
dragon76209 what's your setup on linux with a PS3 controller, my "sudo xboxdrv --mimic-xpad --silent" doesn't work as expected (I want the same scheme as Shank 1 to play)
Pixel Lover Jan 20 @ 1:49pm 
hey just curious thinking about buying this but if the demo works the game should work right?
DameKDamian Feb 19 @ 8:48am 
;P
Showing 1-13 of 13 comments
< >
Per page: 15 30 50