Xegethra Jan 30, 2013 @ 1:53pm
My Sim can't navigate the map anymore.
Hey there, been playing this game with no problems up until now...I decided to play and to my surprise, my Sim no longer wants to walk anywhere. I can get her to walk outside the castle front, but she refuses to go down the hillside, telling me her path is blocked...she will NOT go anywhere at all. I don't know what's wrong, I've tried things like checking the integrity of the game files, I've done the standard un-install and re install....but nothing works.

Does anybody have an idea of what's wrong or what I can do to fix this? I can't play the game if my Sim doesn't go anywhere.
Showing 1-6 of 6 comments
< >
Myrjala Raven Mar 18, 2013 @ 8:57pm 
I have just run into this very same problem...
Has there been any word on how to fix this issue, or is it just another one of EA's big feck ups?
Xegethra Mar 19, 2013 @ 7:08am 
I think it's a screw up that will go un resolved...my Sims, old and new keep doing it. A shame really, the game wasn't too bad other than that problem I though
[RFA] The DuDe Jul 21, 2013 @ 11:50pm 
When your sims, or Monarch, gets stuck within the castle, wont leave, and tantrum that his path is blocked.. you have to place the bed somewhere else.. other side of the room perhaps. or just set it to the other wall.

If that doesnt work, try switching some other stuff around...

It sounds strange, but it worked for me.... cant hurt to try...
Xegethra Jul 22, 2013 @ 7:13am 
Well, she is outside when this happens. She just refuses to leave. She will get a certain way down the hill and then just not go anymore, despite passing by there before, all of a sudden eveywhere is a no go zone.

Unless you mean the stuff in castle affects how your sim moves outside? In that case, that does indeed sound strange.
glwardberg Aug 11, 2013 @ 8:09am 
Same deal - no outside movement (and I'm trying to interact with another character who hangs around the forest) But lately characters aren't leaving/entering the castle either; so I can't continue the 'quest'. I'll try the 'movement' of furnishing idea. Also noticed my SIM gets constantly caught up in non-quest activities by npc's inside the castle.
glw
glwardberg Aug 11, 2013 @ 10:55am 
For those who have the same problem - you've probably solved it with this furniture movement trick. It does seem to work. I moved various things around and SIMs were back to normal. But I can't seem to get my monarch to marry his suitor, despite really long woo time/effort. Any ideas? The interaction has been fully green/best friend for ten days or so. Lessons say marriage proposal option should show up in Romantic interface. Not yet! My goal time/performance is probably going to sink to the lowest level.
glw
Showing 1-6 of 6 comments
< >
Per page: 15 30 50