Prototype > General Discussions > Topic Details
MetalPlague Nov 29, 2013 @ 10:25am
A compilation of fixes.
I have to say that if you have a modern spec PC... without any third party programs or using your graphics card control panel, Prototype is extremely painful to play. From what I've been reading so far, a lot of people have been having various issues such as the game failing to detect graphics cards that have higher than 2GB (an issue I ran into), frame stuttering, mouse lag/broken mouse movement (sometimes the mouse will not register movement), and sound issues. I've done a little reading, researching, and tinkering and found what works for me, so I figured I would pass on my findings for the number of issues I have experienced and ones that I am aware of and familiar with. First, let me post up my specs so you guys know what kind of system I'm working with.

CPU: Intel Core i7 Quad Core 2660K (2nd Gen i7)
RAM: 8GB
GPU: EVGA nVidia GeForce GTX 660 Superclocked 3GB
OS: Windows 7 64-bit

First of all, there is the resolution bug where it will not detect your graphics card if you have more than 2GB of memory. Me, running a GTX 660 3GB, it was obviously the first thing I noticed the moment I went into the options screen after I first launched the game. So, I did some reading on several forums and came across this solution that EvilDasterd posted up here on the Steam forums. You go to this link > http://www.wsgf.org/dr/prototype < , download the "Prototype_All_Res.zip" file under the "Solutions & Anomalies" section. You unzip that file, extract, and copy "prototypeenginef.dll" to your Prototype folder in your Steam Directory. The only drawback there is to this is that you can't change your resolution from the in-game menu. All other settings seem to work fine without completely undoing the fix. With this fix, I would recommend disabling your Steam Cloud Sync to keep it from potentially overwriting and undoing the fix, as I have found that it does the same thing with my edited config file for Doom 3. Also, if anything goes wrong with this file... If it glitches up your game or causes it to crash to desktop, you can always delete it and retrieve your old one by repairing your install.

The next fix is quite a crucial one to those of you with low frame rate problems (in the teens or worse. These problems are not unique to this game alone, as the original F.E.A.R. and Condemned: Criminal Origins also suffer from this same bug. For whatever reason, HID devices will leech or restrict the resources needed to run these games. This is most common with Logitech keyboards and mice, as I found with my G19 keyboard, and G9X mouse. You will have to disable all the "HID-compliant device"s in device manager in Human Interface Devices, excluding the ones that allow the basic functions of your mouse and keyboard. Yes, if you have more advanced keyboards with LCD screens and such, you will have to do without those features as you play. But there is no other work around for this. At least it will upgrade your copy of Prototype: Slideshow Edition to the standard game. :P

I see several issues here in the forums about frame rate stutter and broken mouse controls. I did a little digging on this and the only fix I was able to find was by limiting the frame rate to about 30FPS. Running at higher frames tended to yield bad results. Lots of frame stutter regardless of having V-Sync on or off, and sometimes my mouse would not register movement. This is also not the other game that suffers from this. The original Dead Space I had to cap to 30 FPS, otherwise the mouse controls would break in a way that would make them too weak. Not quite like Prototype, because Prototype's mouse controls will quit registering for brief periods, which makes it just as frustrating when you're in a pretty heavy fight. In order to do this, there are several methods. I'll go over mine. I use the RivaTuner Statistics Server tool that I got with my EVGA PrecisionX. I add it to the list of programs to give it its individual settings, and raise the detection level up to medium for it only and type in 30 in the Frame Rate Limiter field. Make sure that Prototype's .exe is selected, otherwise if you use "Global", it will apply to every game or 3D-accelerated program you run. I found that in running Windows 7 Service Pack 1 that RTSS will rarely work on anything, so if you desperately want to play this game with some stability, you will have to downgrade from SP1 to the base installation. Also, when you run a game at 30fps, you may see considerable mouse input lag. To remedy this, I use my nVidia Control Panel, and set the "Maxiumum pre-rendered frames" to 1. This will minimize input lag and make playing at a 30FPS rate more bearable. Remember to do this for only the process or .exe instead of through Global Settings, unless you intend to use that exact same value on everything you run.

And also... for those of you having audio issues, be sure to set your sample rate to no higher than 24-bit/48Khz, or 24-bit/44.1Khz. If you're having issues with audio stuttering or high pitched "chipmunk" voices, this should fix your problem.

If anyone else has any fixes feel free to tack them onto this post. I'm sure this will make looking for solutions to fix this game less problematic.
Last edited by MetalPlague; Nov 29, 2013 @ 10:28am
Showing 1-11 of 11 comments
< >
MetalPlague Nov 30, 2013 @ 6:08am 
Update on the FPS Limiter: It does not have to be capped at 30FPS to restore controls and stablize your frame rate. I just did a small test with RivaTuner Statistic Server set to 60FPS and controls were still good.
Affliction Dec 11, 2013 @ 7:55pm 
What if the only HID devices that show in device manager are my basic mouse and keyboard (which are Logitech but they are just basic USB keyboard & mouse, nothing fancy)? If I were to disable those two they wouldn't work at all right?

Thanks for the tips! This game is on my backlog list but I will be starting it soon and I already have the resolution fixed (I have a Radeon 7950 3GB so it limits me without the fix) but I haven't tested out the perfomance of the game yet...hopefully it runs decent!

Thanks SO much though! It's nice to see people sharing fixes and trying to help instead of just creating a bunch of THIS GAME SUCKS threads.
Last edited by Affliction; Dec 11, 2013 @ 7:56pm
ZiggyTouyeul Dec 29, 2013 @ 9:34pm 
I'm so ♥♥♥♥ed, HID fixe that works for everyone doesn't for me. I disabled every single HID devices and I still get terrible low fps.
Hitchet Mar 20 @ 2:50pm 
"The game starts fine. I can access the menu without a problem, but when I try and start a game it will crash on the loading screen." - This is my problem. Dont u know something how to fix this?
cranialocially Mar 20 @ 9:17pm 
i too run logitech. the mk700 board and 705 mouse. . i have an issue that is unlike anyone elses. in a way its kinda like hitchets buit not nearly as devastating. my game will start just fine . work at great framerate with all graphics just crisp and clear as a bell. trucking up a building and boost gliding like a madman. then if i dont enter into a confrontation that takes some effort the framerate will gradually drop. you dont really noptice it initially but without fighting you may get a good eight to ten minutes before youre abnle to recognize its time to save . quit to desktop and immediately reopen the game to do it all over again. now if i decide to do a mssion that will take a considerable fight to prevail; then 2 mins tops and im about had enough of trying to achieve my objectiveand complete that mission.so damn irritating. ive tried everything i know and some of the things youve said to no avail. i use the xbox 360 afterglow gamepad and keyboard or mouse doesnt make 2 squirts of ♥♥♥♥ worth of any difference. maybe ill disable then see what happens. do you thing my usb 3,0 might be conflicting with the program???? i wish radical ent still exhisted. i love this damn game. i hate these issues though this may sound asinine but i have prototype and prototype 2 for the ps3 and i would rather play this because my pc just looks and responds so much better until it doesnt of course...anyway keep em coming guys. thanx for your effort . activision doesnt support worth a crap. i rely on this forum and community. thanx ACTIVISION for ♥♥♥♥♥♥ us without a kiss! forgive my typos and sharp toungued language....
.
cranialocially Mar 20 @ 9:29pm 
whoops i failed to mention running windows 7x64 with 3rd gen I-5 3350p/3.1ghz turbo3.3ghz 16gb ram. and im using the msi geforce gtx760tf oc edition 2gbs. but it does the same thing when i have the gtx650 with 1gb. no difference at all.
Last edited by cranialocially; Mar 20 @ 9:30pm
Vyvyn CruxButt Mar 27 @ 6:24am 
Just putting this out there, But as far as removing the HID/Other non-existant USB devices, This page is a godsend: http://www.faqforge.com/windows/uninstall-usb-drivers-on-windows-7/

It shows how to set a variable that will show ALL HID/USB and other drivers/Hardware components that aren't installed, So they can be fixed/Removed easily. Well, As easy as it is to click on a few hundred items. :P
-=Adzy=- Apr 6 @ 12:34am 
After 3 years I reinstalled today. Ran into every error mentioned on this thread.. (Sigh)
Uninstall.
ZiggyTouyeul Apr 6 @ 2:41am 
My fix > Unplug my usb keyboard and mouse after I launch the game, and play with the Xbox360 gamepad. Worse part is that it doesn't work 100% of the time. Really preventing me from finishing the game because I lack the motivation of unplugging my essential peripherals each time I have to play... :/
Derviish May 5 @ 8:33pm 
With the audio issues; how do I "set your sample rate to no higher than 24-bit/48Khz, or 24-bit/44.1Khz."? Is that an in game thing or is it something I have to do outside of it? Also the porblem with the sound is that it is basically running 3 to 4 times faster than it should. Everything else is working fine for me, but the sound is too fast.
Last edited by Derviish; May 5 @ 8:35pm
thekevster (do not bother) May 5 @ 10:52pm 
everything i fine for me but when I tweak the graphics it still looks the same. wich in default its set at low with no aa any fix to that?
Showing 1-11 of 11 comments
< >
Per page: 15 30 50