Arcturan Mega Boner Sep 13, 2013 @ 4:00pm
KQ7 says it wont run on a 64bit machine.
advice?
Showing 1-9 of 9 comments
< >
nyxus Sep 13, 2013 @ 5:00pm 
tried to play an old (non-steam) version of KQ7 some time ago on a 64bit machine, i made it about 2/3 of the way through (to halloween town) and then hit a quest that involves carrying around a lit firecracker... unless they've fixed something, this quest (and therefore the game) can't be finished on new hardware - the internal timer is obviously tied to the CPU and the firecracker blows up almost immediately. - could have been just my game, or just me, but i'm inclined to think its the game.
Arcturan Mega Boner Sep 13, 2013 @ 5:25pm 
It wont even start for me, i get the immediate mismatching version error.
Crosis47 Sep 25, 2013 @ 11:56pm 
Use VMWare and make a virtual machine with the recommended specs for the game and run it on that
Arcturan Mega Boner Sep 26, 2013 @ 1:33am 
thx for the reply, i'll try that next time, i gave up and got mad :(
jet fuel can't melt steel memes Sep 26, 2013 @ 4:36pm 
I found this on SPUF, though I'm not sure if it works.
http://forums.steampowered.com/forums/showthread.php?t=925982
Last edited by jet fuel can't melt steel memes; Sep 26, 2013 @ 4:58pm
coldlights Feb 26, 2014 @ 4:55am 
I've tried everything top to bottom on all of these threads and including the few above, but end of the day I'm still getting the .999 error. Super frustrated as I love these games and 7 is the only one that won't work.

Using Win 7 64bit
rogerrabbit46 Aug 25, 2014 @ 8:34am 
here the same "app" wont start/run.
stevenloveland Aug 26, 2014 @ 11:44am 
Originally posted by rogerrabbit46:
here the same "app" wont start/run.

What have you tried thus far?
TAFKAP3121 Aug 28, 2014 @ 12:32pm 
When King's Quest VII was originally released it was initially made only available on Windows 3.1. Later editions would include a DOS interpreter but unfortunately this collection only includes the original release, as such it cannot be run through DOSBox like the first six titles. x64 versions of Windows do not feature backwards compatibility with 16-bit applications but users should be able to run KQ7 in XP Mode[windows.microsoft.com]. However, this option is only available to users with Windows 7 x64 Professional Edition or higher.
Showing 1-9 of 9 comments
< >
Per page: 15 30 50